[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZpfSkENjiIL7HGJV@gmail.com>
Date: Wed, 17 Jul 2024 16:17:52 +0200
From: Ingo Molnar <mingo@...nel.org>
To: Linus Torvalds <torvalds@...ux-foundation.org>
Cc: linux-kernel@...r.kernel.org, the arch/x86 maintainers <x86@...nel.org>,
Uros Bizjak <ubizjak@...il.com>
Subject: [GIT PULL] x86/percpu changes for v6.11
Linus,
Please pull the latest x86/percpu Git tree from:
git://git.kernel.org/pub/scm/linux/kernel/git/tip/tip.git x86-percpu-2024-07-17
# HEAD: 47ff30cc1be7bf426c03ecc84371452109b416e4 x86/percpu: Enable named address spaces for all capable GCC versions
x86/percpu changes for v6.11:
- Enable the named address spaces based percpu accessors optimization
on all GCC versions that contain this feature, detected through
a build-time testcase. This effectively enables the feature on
GCC 6, GCC 7 and GCC 8 versions.
- Fix operand constraint modifier in __raw_cpu_write()
- Reorganize the per-CPU headers for better readability
- Misc cleanups and fixes
Thanks,
Ingo
------------------>
Ingo Molnar (2):
x86/percpu: Clean up <asm/percpu.h> a bit
x86/percpu: Clean up <asm/percpu.h> vertical alignment details
Uros Bizjak (8):
x86/percpu: Introduce the pcpu_binary_op() macro
x86/percpu: Move some percpu macros around for readability
x86/percpu: Unify percpu read-write accessors
x86/percpu: Introduce the __raw_cpu_read_const() macro
x86/percpu: Fix operand constraint modifier in __raw_cpu_write()
x86/percpu: Rename percpu_stable_op() to __raw_cpu_read_stable()
x86/percpu: Move some percpu accessors around to reduce ifdeffery
x86/percpu: Enable named address spaces for all capable GCC versions
arch/x86/Kconfig | 3 +-
arch/x86/include/asm/percpu.h | 535 ++++++++++++++++++++++--------------------
2 files changed, 281 insertions(+), 257 deletions(-)
Powered by blists - more mailing lists