[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20240718105903.19617-1-osalvador@suse.de>
Date: Thu, 18 Jul 2024 12:58:54 +0200
From: Oscar Salvador <osalvador@...e.de>
To: Andrew Morton <akpm@...ux-foundation.org>
Cc: linux-kernel@...r.kernel.org,
linux-mm@...ck.org,
Peter Xu <peterx@...hat.com>,
Muchun Song <muchun.song@...ux.dev>,
Michal Hocko <mhocko@...e.com>,
Donet Tom <donettom@...ux.ibm.com>,
"Kirill A . Shutemov" <kirill.shutemov@...ux.intel.com>,
Matthew Wilcox <willy@...radead.org>,
Vlastimil Babka <vbabka@...e.cz>,
Oscar Salvador <osalvador@...e.de>
Subject: [PATCH 0/9] Unify hugetlb into arch_get_unmapped_area functions
Hi all,
this is a first attempt to get rid of a fair amount of duplicated code
wrt. hugetlb and *get_unmapped_area* functions.
HugeTLB registers a .get_unmapped_area function which gets called from
__get_unmapped_area().
hugetlb_get_unmapped_area() is defined by a bunch of architectures and
it also has a generic definition for those that do not define it.
Short-long story is that there is a ton of duplicated code between
specific hugetlb *_get_unmapped_area_* functions and mm-core functions,
so we can do better by teaching arch_get_unmapped_area* functions how
to deal with hugetlb mappings.
Note that not a lot of things need to be taught though.
hugetlb_mmap_check_and_align(), that gets called for hugetlb mappings
prior to call mm_get_unmapped_area_vmflags(), runs some sanity checks
and aligns the addr to huge_page_size(), so we do not need to that
down the road in the respective {generic,arch}_get_unmapped_area*
functions.
More information can be found in the respective patches.
LTP mmapstress and hugemmap testcases were ran succesfully on:
- arm64
- powerpc64
- s390
- x86_64
Oscar Salvador (9):
mm/mmap: Teach generic_get_unmapped_area{_topdown} to handle hugetlb
mappings
arch/s390: Teach arch_get_unmapped_area{_topdown} to handle hugetlb
mappings
arch/x86: Teach arch_get_unmapped_area_vmflags to handle hugetlb
mappings
arch/sparc: Teach arch_get_unmapped_area{_topdown} to handle hugetlb
mappings
arch/powerpc: Teach book3s64 arch_get_unmapped_area{_topdown} to
handle hugetlb mappings
mm: Make hugetlb mappings go through mm_get_unmapped_area_vmflags
mm: Drop hugetlb_get_unmapped_area{_*} functions
arch/s390: Clean up hugetlb definitions
mm: Consolidate common checks in hugetlb_mmap_check_and_align
arch/loongarch/include/asm/hugetlb.h | 4 -
arch/mips/include/asm/hugetlb.h | 4 -
arch/parisc/include/asm/hugetlb.h | 15 ----
arch/parisc/mm/hugetlbpage.c | 23 ------
arch/powerpc/mm/book3s64/slice.c | 49 +++++++-----
arch/s390/include/asm/hugetlb.h | 73 ++++--------------
arch/s390/mm/hugetlbpage.c | 84 ---------------------
arch/s390/mm/mmap.c | 9 ++-
arch/sh/include/asm/hugetlb.h | 15 ----
arch/sparc/kernel/sys_sparc_32.c | 16 +++-
arch/sparc/kernel/sys_sparc_64.c | 36 +++++++--
arch/sparc/mm/hugetlbpage.c | 108 ---------------------------
arch/x86/kernel/sys_x86_64.c | 24 ++++--
arch/x86/mm/hugetlbpage.c | 100 -------------------------
fs/hugetlbfs/inode.c | 92 ++---------------------
include/asm-generic/hugetlb.h | 15 ++--
include/linux/hugetlb.h | 21 +++---
mm/mmap.c | 19 ++++-
18 files changed, 153 insertions(+), 554 deletions(-)
--
2.45.2
Powered by blists - more mailing lists