lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20240723-kredit-bohrloch-2942d7c53f78@brauner>
Date: Tue, 23 Jul 2024 09:47:15 +0200
From: Christian Brauner <brauner@...nel.org>
To: Jan Kara <jack@...e.cz>
Cc: 47 Mohit Pawar <mohitpawar@...aoe.ac.in>, 
	linux-fsdevel@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 3/3] Fixed: fs: file_table_c: Missing blank line warnings

On Mon, Jul 22, 2024 at 06:37:41PM GMT, Jan Kara wrote:
> On Mon 15-07-24 09:26:29, 47 Mohit Pawar wrote:
> > From: Mohit0404 <mohitpawar@...aoe.ac.in>
> > 
> > Fixed-
> >         WARNING: Missing a blank line after declarations
> >         WARNING: Missing a blank line after declarations
> 
> The patch is missing your Signed-off-by tag. Please add it. Also I'm not
> sure how Christian sees these pure whitespace cleanups but in this case it

I'm personally pro such cleanups.

> is probably at least a readability win so feel free to add:
> 
> Reviewed-by: Jan Kara <jack@...e.cz>
> 
> 								Honza
> 
> > ---
> >  fs/file_table.c | 2 ++
> >  1 file changed, 2 insertions(+)
> > 
> > diff --git a/fs/file_table.c b/fs/file_table.c
> > index 4f03beed4737..9950293535e4 100644
> > --- a/fs/file_table.c
> > +++ b/fs/file_table.c
> > @@ -136,6 +136,7 @@ static int __init init_fs_stat_sysctls(void)
> >         register_sysctl_init("fs", fs_stat_sysctls);
> >         if (IS_ENABLED(CONFIG_BINFMT_MISC)) {
> >                 struct ctl_table_header *hdr;
> > +
> >                 hdr = register_sysctl_mount_point("fs/binfmt_misc");
> >                 kmemleak_not_leak(hdr);
> >         }
> > @@ -384,6 +385,7 @@ struct file *alloc_file_clone(struct file *base, int
> > flags,
> >                                 const struct file_operations *fops)
> >  {
> >         struct file *f = alloc_file(&base->f_path, flags, fops);
> > +
> >         if (!IS_ERR(f)) {

I would then change that to:

struct file *f;

f = alloc_file(&base->f_path, flags, fops);
if (!IS_ERR(f)) {

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ