[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <efcee12c-3ae9-4f40-8739-ac706a9fa33a@amd.com>
Date: Wed, 7 Aug 2024 11:11:30 +0530
From: Ravi Bangoria <ravi.bangoria@....com>
To: Tom Lendacky <thomas.lendacky@....com>, tglx@...utronix.de,
mingo@...hat.com, bp@...en8.de, dave.hansen@...ux.intel.com,
seanjc@...gle.com, pbonzini@...hat.com, jmattson@...gle.com
Cc: hpa@...or.com, rmk+kernel@...linux.org.uk, peterz@...radead.org,
james.morse@....com, lukas.bulwahn@...il.com, arjan@...ux.intel.com,
j.granados@...sung.com, sibs@...natelecom.cn, nik.borisov@...e.com,
michael.roth@....com, nikunj.dadhania@....com, babu.moger@....com,
x86@...nel.org, kvm@...r.kernel.org, linux-kernel@...r.kernel.org,
santosh.shukla@....com, ananth.narayan@....com, sandipan.das@....com,
manali.shukla@....com, Ravi Bangoria <ravi.bangoria@....com>
Subject: Re: [PATCH v3 4/4] KVM: SVM: Add Bus Lock Detect support
>> diff --git a/arch/x86/kvm/svm/nested.c b/arch/x86/kvm/svm/nested.c
>> index 6f704c1037e5..97caf940815b 100644
>> --- a/arch/x86/kvm/svm/nested.c
>> +++ b/arch/x86/kvm/svm/nested.c
>> @@ -586,7 +586,8 @@ static void nested_vmcb02_prepare_save(struct vcpu_svm *svm, struct vmcb *vmcb12
>> /* These bits will be set properly on the first execution when new_vmc12 is true */
>> if (unlikely(new_vmcb12 || vmcb_is_dirty(vmcb12, VMCB_DR))) {
>> vmcb02->save.dr7 = svm->nested.save.dr7 | DR7_FIXED_1;
>> - svm->vcpu.arch.dr6 = svm->nested.save.dr6 | DR6_ACTIVE_LOW;
>> + /* DR6_RTM is not supported on AMD as of now. */
>> + svm->vcpu.arch.dr6 = svm->nested.save.dr6 | DR6_FIXED_1 | DR6_RTM;
>
> This took me having to look at the APM, so maybe expand on this comment
> for now to indicate that DR6_RTM is a reserved bit on AMD and as such
> much be set to 1.
Sure.
> Does this qualify as a fix?
I don't think so. Above change fixes Bus Lock Detect support for nested
SVM guests. But without this (whole) patch, Bus Lock Detect isn't even
supported in the virt environment.
>> diff --git a/arch/x86/kvm/svm/svm.c b/arch/x86/kvm/svm/svm.c
>> index 85631112c872..68ef5bff7fc7 100644
>> --- a/arch/x86/kvm/svm/svm.c
>> +++ b/arch/x86/kvm/svm/svm.c
>> @@ -1047,7 +1047,8 @@ void svm_update_lbrv(struct kvm_vcpu *vcpu)
>> {
>> struct vcpu_svm *svm = to_svm(vcpu);
>> bool current_enable_lbrv = svm->vmcb->control.virt_ext & LBR_CTL_ENABLE_MASK;
>> - bool enable_lbrv = (svm_get_lbr_vmcb(svm)->save.dbgctl & DEBUGCTLMSR_LBR) ||
>> + u64 dbgctl_buslock_lbr = DEBUGCTLMSR_BUS_LOCK_DETECT | DEBUGCTLMSR_LBR;
>> + bool enable_lbrv = (svm_get_lbr_vmcb(svm)->save.dbgctl & dbgctl_buslock_lbr) ||
>> (is_guest_mode(vcpu) && guest_can_use(vcpu, X86_FEATURE_LBRV) &&
>> (svm->nested.ctl.virt_ext & LBR_CTL_ENABLE_MASK));
>
> This statement is getting pretty complicated! I'm not sure if there's a
> better way that is more readable. Maybe start with a value and update it
> using separate statements? Not critical, though.
That would be more or less a revert of:
https://git.kernel.org/torvalds/c/41dfb5f13ed91
So, I'm thinking to keep it as is.
Thanks for the review,
Ravi
Powered by blists - more mailing lists