[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAGXv+5H8LBGQWC9uJk_ai8d5pfCA7FZMnDQve2QfTeA74acXmg@mail.gmail.com>
Date: Thu, 5 Sep 2024 16:49:12 +0800
From: Chen-Yu Tsai <wenst@...omium.org>
To: Andy Shevchenko <andy.shevchenko@...il.com>
Cc: Mark Brown <broonie@...nel.org>, linux-kernel@...r.kernel.org,
Liam Girdwood <lgirdwood@...il.com>
Subject: Re: [PATCH v1 1/1] regulator: of: Refactor of_get_*regulator() to
decrease indentation
On Thu, Sep 5, 2024 at 3:09 AM Andy Shevchenko
<andy.shevchenko@...il.com> wrote:
>
> Refactor of_get_*regulator() to decrease indentation and increase readability.
> No functional changes intended.
>
> Signed-off-by: Andy Shevchenko <andy.shevchenko@...il.com>
Reviewed-by: Chen-Yu Tsai <wenst@...omium.org>
> ---
> drivers/regulator/of_regulator.c | 28 ++++++++++++----------------
> 1 file changed, 12 insertions(+), 16 deletions(-)
>
> diff --git a/drivers/regulator/of_regulator.c b/drivers/regulator/of_regulator.c
> index d5dd7a9e577b..3f490d81abc2 100644
> --- a/drivers/regulator/of_regulator.c
> +++ b/drivers/regulator/of_regulator.c
> @@ -572,14 +572,12 @@ static struct device_node *of_get_child_regulator(struct device_node *parent,
>
> for_each_child_of_node(parent, child) {
> regnode = of_parse_phandle(child, prop_name, 0);
> -
> - if (!regnode) {
> - regnode = of_get_child_regulator(child, prop_name);
> - if (regnode)
> - goto err_node_put;
Nit: I would probably rename this to out_node_put. But if we're going to
move to the scoped helper, we might as well just skip it.
> - } else {
> + if (regnode)
> + goto err_node_put;
> +
> + regnode = of_get_child_regulator(child, prop_name);
> + if (regnode)
> goto err_node_put;
> - }
> }
> return NULL;
>
> @@ -607,17 +605,15 @@ static struct device_node *of_get_regulator(struct device *dev, const char *supp
>
> snprintf(prop_name, 64, "%s-supply", supply);
> regnode = of_parse_phandle(dev->of_node, prop_name, 0);
> + if (regnode)
> + return regnode;
>
> - if (!regnode) {
> - regnode = of_get_child_regulator(dev->of_node, prop_name);
> - if (regnode)
> - return regnode;
> + regnode = of_get_child_regulator(dev->of_node, prop_name);
> + if (regnode)
> + return regnode;
>
> - dev_dbg(dev, "Looking up %s property in node %pOF failed\n",
> - prop_name, dev->of_node);
> - return NULL;
> - }
> - return regnode;
> + dev_dbg(dev, "Looking up %s property in node %pOF failed\n", prop_name, dev->of_node);
> + return NULL;
> }
>
> static struct regulator_dev *of_find_regulator_by_node(struct device_node *np)
> --
> 2.46.0
>
Powered by blists - more mailing lists