lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20240906162555.30071-1-sj@kernel.org>
Date: Fri,  6 Sep 2024 09:25:55 -0700
From: SeongJae Park <sj@...nel.org>
To: Anna-Maria Behnsen <anna-maria@...utronix.de>
Cc: SeongJae Park <sj@...nel.org>,
	Frederic Weisbecker <frederic@...nel.org>,
	Thomas Gleixner <tglx@...utronix.de>,
	Jonathan Corbet <corbet@....net>,
	linux-kernel@...r.kernel.org,
	Len Brown <len.brown@...el.com>,
	"Rafael J. Wysocki" <rafael@...nel.org>,
	Andrew Morton <akpm@...ux-foundation.org>,
	damon@...ts.linux.dev,
	linux-mm@...ck.org
Subject: Re: [PATCH 05/15] timers: Rename sleep_idle_range() to sleep_range_idle()

On Wed, 04 Sep 2024 15:04:55 +0200 Anna-Maria Behnsen <anna-maria@...utronix.de> wrote:

> sleep_idle_range() is a variant of sleep_range(). Both are using
> sleep_range_state() as a base. To be able to find all the related functions
> in one go, rename it sleep_idle_range() to sleep_range_idle().

Nit.  s/sleep_/usleep_/?

> 
> No functional change.
> 
> Cc: SeongJae Park <sj@...nel.org>
> Cc: Andrew Morton <akpm@...ux-foundation.org>
> Cc: damon@...ts.linux.dev
> Cc: linux-mm@...ck.org
> Signed-off-by: Anna-Maria Behnsen <anna-maria@...utronix.de>
> ---
>  include/linux/delay.h | 2 +-
>  mm/damon/core.c       | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/include/linux/delay.h b/include/linux/delay.h
> index ff9cda975e30..2bc586aa2068 100644
> --- a/include/linux/delay.h
> +++ b/include/linux/delay.h
> @@ -68,7 +68,7 @@ static inline void usleep_range(unsigned long min, unsigned long max)
>  	usleep_range_state(min, max, TASK_UNINTERRUPTIBLE);
>  }
>  
> -static inline void usleep_idle_range(unsigned long min, unsigned long max)
> +static inline void usleep_range_idle(unsigned long min, unsigned long max)
>  {
>  	usleep_range_state(min, max, TASK_IDLE);
>  }
> diff --git a/mm/damon/core.c b/mm/damon/core.c
> index 7a87628b76ab..94fe2f1f9b0e 100644
> --- a/mm/damon/core.c
> +++ b/mm/damon/core.c
> @@ -1887,7 +1887,7 @@ static void kdamond_usleep(unsigned long usecs)
>  	if (usecs > 20 * USEC_PER_MSEC)
>  		schedule_timeout_idle(usecs_to_jiffies(usecs));
>  	else
> -		usleep_idle_range(usecs, usecs + 1);
> +		usleep_range_idle(usecs, usecs + 1);
>  }
>  
>  /* Returns negative error code if it's not activated but should return */


Other than the trivial nit,

Reviewed-by: SeongJae Park <sj@...nel.org>


Thanks,
SJ

> 
> -- 
> 2.39.2
> 
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ