[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Zv0HotHuCGDpmFp7@infradead.org>
Date: Wed, 2 Oct 2024 01:43:14 -0700
From: Christoph Hellwig <hch@...radead.org>
To: Christian Marangi <ansuelsmth@...il.com>
Cc: Jens Axboe <axboe@...nel.dk>, Jonathan Corbet <corbet@....net>,
Ulf Hansson <ulf.hansson@...aro.org>, Rob Herring <robh@...nel.org>,
Krzysztof Kozlowski <krzk+dt@...nel.org>,
Conor Dooley <conor+dt@...nel.org>,
INAGAKI Hiroshi <musashino.open@...il.com>,
Daniel Golle <daniel@...rotopia.org>,
Christian Brauner <brauner@...nel.org>,
Al Viro <viro@...iv.linux.org.uk>, Ming Lei <ming.lei@...hat.com>,
Jan Kara <jack@...e.cz>, Li Lingfeng <lilingfeng3@...wei.com>,
Christian Heusel <christian@...sel.eu>,
Avri Altman <avri.altman@....com>,
Adrian Hunter <adrian.hunter@...el.com>,
Linus Walleij <linus.walleij@...aro.org>,
Mikko Rapeli <mikko.rapeli@...aro.org>,
Riyan Dhiman <riyandhiman14@...il.com>,
Jorge Ramirez-Ortiz <jorge@...ndries.io>,
Dominique Martinet <dominique.martinet@...ark-techno.com>,
Jens Wiklander <jens.wiklander@...aro.org>,
Christophe JAILLET <christophe.jaillet@...adoo.fr>,
Li Zhijian <lizhijian@...itsu.com>, linux-block@...r.kernel.org,
linux-doc@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-mmc@...r.kernel.org, devicetree@...r.kernel.org,
Lorenzo Bianconi <lorenzo@...nel.org>,
Miquel Raynal <miquel.raynal@...tlin.com>, upstream@...oha.com
Subject: Re: [PATCH v5 5/6] block: add support for partition table defined in
OF
On Wed, Oct 02, 2024 at 12:18:57AM +0200, Christian Marangi wrote:
> +static int validate_of_partition(struct device_node *np, int slot)
> +{
> + int a_cells, s_cells;
> + const __be32 *reg;
> + u64 offset, size;
> + int len;
> +
> + reg = of_get_property(np, "reg", &len);
> +
> + a_cells = of_n_addr_cells(np);
> + s_cells = of_n_size_cells(np);
Just personal preference, but I find code easier to read if variables
are initialized at declaration time whenever possible:
const __be32 *reg = of_get_property(np, "reg", &len);
int a_cells = of_n_addr_cells(np);
int s_cells = of_n_size_cells(np);
(same for a few other functions below)
Otherwise looks good:
Reviewed-by: Christoph Hellwig <hch@....de>
Powered by blists - more mailing lists