[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <66fd087c.050a0220.3b87ae.3666@mx.google.com>
Date: Wed, 2 Oct 2024 10:46:46 +0200
From: Christian Marangi <ansuelsmth@...il.com>
To: Christoph Hellwig <hch@...radead.org>
Cc: Jens Axboe <axboe@...nel.dk>, Jonathan Corbet <corbet@....net>,
Ulf Hansson <ulf.hansson@...aro.org>, Rob Herring <robh@...nel.org>,
Krzysztof Kozlowski <krzk+dt@...nel.org>,
Conor Dooley <conor+dt@...nel.org>,
INAGAKI Hiroshi <musashino.open@...il.com>,
Daniel Golle <daniel@...rotopia.org>,
Christian Brauner <brauner@...nel.org>,
Al Viro <viro@...iv.linux.org.uk>, Ming Lei <ming.lei@...hat.com>,
Jan Kara <jack@...e.cz>, Li Lingfeng <lilingfeng3@...wei.com>,
Christian Heusel <christian@...sel.eu>,
Avri Altman <avri.altman@....com>,
Adrian Hunter <adrian.hunter@...el.com>,
Linus Walleij <linus.walleij@...aro.org>,
Mikko Rapeli <mikko.rapeli@...aro.org>,
Riyan Dhiman <riyandhiman14@...il.com>,
Jorge Ramirez-Ortiz <jorge@...ndries.io>,
Dominique Martinet <dominique.martinet@...ark-techno.com>,
Jens Wiklander <jens.wiklander@...aro.org>,
Christophe JAILLET <christophe.jaillet@...adoo.fr>,
Li Zhijian <lizhijian@...itsu.com>, linux-block@...r.kernel.org,
linux-doc@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-mmc@...r.kernel.org, devicetree@...r.kernel.org,
Lorenzo Bianconi <lorenzo@...nel.org>,
Miquel Raynal <miquel.raynal@...tlin.com>, upstream@...oha.com
Subject: Re: [PATCH v5 3/6] block: introduce device_add_of_disk()
On Wed, Oct 02, 2024 at 01:40:58AM -0700, Christoph Hellwig wrote:
> Thanks,
>
> this looks much better. A few minor nitpicks, though:
>
Very happy you like it, yes I wasn't sure what was the correct way to
introduce the helper. If you notice in the blkdev.h we have also add_disk()
that is a static inline wrapper for device_add_disk().
Wonder if device_add_disk() should have the same treatement? No idea if
it would cause problem with symbol with external modules, that is why I
used the wrapper.
> > -int __must_check device_add_disk(struct device *parent, struct gendisk *disk,
> > - const struct attribute_group **groups)
> > +static int __device_add_disk(struct device *parent, struct gendisk *disk,
> > + const struct attribute_group **groups,
> > + struct fwnode_handle *fwnode)
>
> I don't think we need a separate helper if device_add_disk simply
> wraps the OF version by passing a NULL fwnode.
>
> > +int __must_check device_add_of_disk(struct device *parent, struct gendisk *disk,
> > + const struct attribute_group **groups,
> > + struct fwnode_handle *fwnode)
> > +{
> > + return __device_add_disk(parent, disk, groups, fwnode);
> > +}
>
> I'd name this as add_disk_fwnode as the of in device_add_of_disk
> reads as in add the device of the disk, and the fwnode is what gets
> passed. The device_ is a bit redundant and just there for historic
> reasons as the original add_disk predates the device model.
>
> Can you also add a kerneldoc comment for the new helper?
>
sure! I will wait the usual 24h to respin this.
> > +EXPORT_SYMBOL(device_add_of_disk);
>
> EXPORT_SYMBO_GPL, please.
>
ack.
--
Ansuel
Powered by blists - more mailing lists