[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <87492b3f-84d1-426f-ad71-7784a1c1dfc3@linuxfoundation.org>
Date: Fri, 11 Oct 2024 17:00:41 -0600
From: Shuah Khan <skhan@...uxfoundation.org>
To: Chen Ni <nichen@...as.ac.cn>, jstultz@...gle.com, tglx@...utronix.de,
sboyd@...nel.org, anna-maria@...utronix.de, frederic@...nel.org,
shuah@...nel.org
Cc: linux-kernel@...r.kernel.org, linux-kselftest@...r.kernel.org,
Shuah Khan <skhan@...uxfoundation.org>
Subject: Re: [PATCH] selftests: timers: Remove unneeded semicolon
On 10/10/24 01:37, Chen Ni wrote:
> Remove unnecessary semicolons reported by Coccinelle/coccicheck and the
> semantic patch at scripts/coccinelle/misc/semicolon.cocci.
>
> Signed-off-by: Chen Ni <nichen@...as.ac.cn>
> ---
> tools/testing/selftests/timers/set-timer-lat.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/tools/testing/selftests/timers/set-timer-lat.c b/tools/testing/selftests/timers/set-timer-lat.c
> index 5365e9ae61c3..7a1a2382538c 100644
> --- a/tools/testing/selftests/timers/set-timer-lat.c
> +++ b/tools/testing/selftests/timers/set-timer-lat.c
> @@ -79,7 +79,7 @@ char *clockstring(int clockid)
> return "CLOCK_BOOTTIME_ALARM";
> case CLOCK_TAI:
> return "CLOCK_TAI";
> - };
> + }
> return "UNKNOWN_CLOCKID";
> }
>
Looks good to me.
John, I will apply this for next of you are okay with it.
Also I noticed clockstring() is defined in multiple tests.
Any thoughts on removing the duplicates and adding it to
a header file? This will add a dependency on another source
file, but might be good to remove the duplicate code.
thanks,
-- Shuah
Powered by blists - more mailing lists