[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4a54b449-802b-4d76-9551-038a0b05cc51@acm.org>
Date: Tue, 15 Oct 2024 10:40:15 -0700
From: Bart Van Assche <bvanassche@....org>
To: Avri Altman <avri.altman@....com>,
"Martin K . Petersen" <martin.petersen@...cle.com>
Cc: linux-scsi@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] scsi: ufs: Use wait-for-reg in HCE init
On 10/14/24 9:57 PM, Avri Altman wrote:
> Instead of open-coding it. Code simplification - no functional change.
Please use full sentences in the patch description.
> + while (retry) {
Please change this loop from a while-loop into a for-loop.
> + if (!ufshcd_wait_for_register(hba, REG_CONTROLLER_ENABLE, CONTROLLER_ENABLE,
> + CONTROLLER_ENABLE, 1000, 50)) {
> + break;
> } else {
"else" is not needed after a "break" statement, isn't it?
> + dev_err(hba->dev, "Controller enable failed\n");
Please fix the grammar of this message, e.g. by changing this message
into "Enabling controller failed" or "Enabling the controller failed".
Thanks,
Bart.
Powered by blists - more mailing lists