[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZxYgZGYTzINm2lpz@smile.fi.intel.com>
Date: Mon, 21 Oct 2024 12:35:32 +0300
From: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
To: Ilpo Järvinen <ilpo.jarvinen@...ux.intel.com>
Cc: LKML <linux-kernel@...r.kernel.org>,
platform-driver-x86@...r.kernel.org,
Mika Westerberg <mika.westerberg@...ux.intel.com>,
Hans de Goede <hdegoede@...hat.com>, Ferry Toth <fntoth@...il.com>
Subject: Re: [PATCH v2 1/3] platform/x86: intel_scu_ipc: Replace workaround
by 32-bit IO
On Mon, Oct 21, 2024 at 12:24:57PM +0300, Ilpo Järvinen wrote:
> On Mon, 21 Oct 2024, Andy Shevchenko wrote:
>
> > The theory is that the so called workaround in pwr_reg_rdwr() is
> > the actual reader of the data in 32-bit chunks. For some reason
> > the 8-bit IO won't fail after that. Replace the workaround by using
> > 32-bit IO explicitly and then memcpy() as much data as was requested
> > by the user. The same approach is already in use in
> > intel_scu_ipc_dev_command_with_size().
...
> > err = intel_scu_ipc_check_status(scu);
> > - if (!err && id == IPC_CMD_PCNTRL_R) { /* Read rbuf */
> > - /* Workaround: values are read as 0 without memcpy_fromio */
> > - memcpy_fromio(cbuf, scu->ipc_base + 0x90, 16);
> > - for (nc = 0; nc < count; nc++)
> > - data[nc] = ipc_data_readb(scu, nc);
> > + if (!err) { /* Read rbuf */
>
> What is the reason for the removal of that id check? This seems a clear
> logic change but why? And if you remove want to remove that check, what
> that comment then means?
Let me split this to a separate change with better explanation then.
> > + for (nc = 0, offset = 0; nc < 4; nc++, offset += 4)
> > + wbuf[nc] = ipc_data_readl(scu, offset);
> > + memcpy(data, wbuf, count);
>
> So do we actually need to read more than
> DIV_ROUND_UP(min(count, 16U), sizeof(u32))? Because that's the approach
> used in intel_scu_ipc_dev_command_with_size() which you referred to.
I'm not sure I follow. We do IO for whole (16-bytes) buffer, but return only
asked _bytes_ to the user.
> > }
> > mutex_unlock(&ipclock);
> > return err;
>
> FYI (unrelated to this patch), there seems to be some open-coded
> FIELD_PREP()s in pwr_reg_rdwr(), some of which is common code between
> those if branches too.
This code is quite old and full of tricks that has to be tested. So, yes
while it's possible to convert, I would like to do it in a small (baby)
steps. This series is already quite intrusive from this perspective :-)
--
With Best Regards,
Andy Shevchenko
Powered by blists - more mailing lists