lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAK7LNASdLT-KQA7+Vn+Y2ZJeropcR-sjmv8p2=DCgzCyQdJAEw@mail.gmail.com>
Date: Thu, 24 Oct 2024 01:39:26 +0900
From: Masahiro Yamada <masahiroy@...nel.org>
To: Rolf Eike Beer <eb@...ix.com>
Cc: linux-kbuild@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 4/7] kconfig: qconf: use QCommandLineParser

On Wed, Oct 23, 2024 at 3:33 PM Rolf Eike Beer <eb@...ix.com> wrote:
>
> This has a much nicer output without manual processing. It also adds window
> management options from Qt for free.
>
> Signed-off-by: Rolf Eike Beer <eb@...ix.com>
> ---

The help message looks as follows:


$ ./scripts/kconfig/qconf --help
QSocketNotifier: Can only be used with threads started with QThread
Usage: ./scripts/kconfig/qconf [options] Kconfig

Options:
  -s          silent
  -h, --help  Displays help on commandline options.
  --help-all  Displays help including Qt specific options.

Arguments:
  file        config file to open



I want to see something better for the explanation of '-s'
and I want 'file' and 'Kconfig' to match.



>  int main(int ac, char** av)
>  {
>         ConfigMainWindow* v;
> -       const char *name;
> +       configApp = new QApplication(ac, av);
> +       QCommandLineParser cmdline;

Please rename 'cmdline' to 'parser' because this is
used in the code example.

https://doc.qt.io/qt-6/qcommandlineparser.html#details



> +       QCommandLineOption silent("s", "silent");

How about  this ?

silent("s", "Print this message and exit.");

The description is consistent with
"./scripts/kconfig/conf --help".



> +       cmdline.addOption(silent);
> +       cmdline.addHelpOption();
> +       cmdline.addPositionalArgument("file", "config file to open", "Kconfig");

I think the third parameter is unneeded.
Then, the help message will look better.




--
Best Regards
Masahiro Yamada

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ