[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20241118143016.c94b7c8ec5d9ed8ae29a66d5@kernel.org>
Date: Mon, 18 Nov 2024 14:30:16 +0900
From: Masami Hiramatsu (Google) <mhiramat@...nel.org>
To: Linus Torvalds <torvalds@...ux-foundation.org>
Cc: Jinjie Ruan <ruanjinjie@...wei.com>, Masami Hiramatsu (Google)
<mhiramat@...nel.org>, Nathan Chancellor <nathan@...nel.org>, Steven
Rostedt <rostedt@...dmis.org>, Masami Hiramatsu <mhiramat@...nel.org>,
linux-kernel@...r.kernel.org
Subject: [GIT PULL] probes: Updates for v6.13
Hi Linus,
Probes update for v6.13:
Kprobes cleanups. Functionality does not change.
- kprobes: Cleanup the config comment
Adjust #endif comments.
- kprobes: Cleanup collect_one_slot() and __disable_kprobe()
Make fail fast to reduce code nested level.
- kprobes: Use struct_size() in __get_insn_slot()
Use struct_size() to avoid special macro.
- x86/kprobes: Cleanup kprobes on ftrace code
Use macro instead of direct field access/magic number, and avoid
redundant instruction pointer setting.
Please pull the latest probes-v6.13 tree, which can be found at:
git://git.kernel.org/pub/scm/linux/kernel/git/trace/linux-trace.git
probes-v6.13
Tag SHA1: 5d620f418ef869a7cdceb38cd32bb7422cb6ae0e
Head SHA1: 4638d7ebeff5a741e22139cf00aaa9db0f668a8c
Jinjie Ruan (2):
kprobes: Cleanup the config comment
kprobes: Cleanup collect_one_slot() and __disable_kprobe()
Masami Hiramatsu (Google) (1):
x86/kprobes: Cleanup kprobes on ftrace code
Nathan Chancellor (1):
kprobes: Use struct_size() in __get_insn_slot()
----
arch/x86/kernel/kprobes/ftrace.c | 19 +++++----
kernel/kprobes.c | 91 +++++++++++++++++++---------------------
2 files changed, 55 insertions(+), 55 deletions(-)
--
Masami Hiramatsu (Google) <mhiramat@...nel.org>
Powered by blists - more mailing lists