[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <Z7XWRfRi3Fn25wT4Dg19JRN4xrKcCt3TxaxZwsR_0LDR2C6fQxCiLrsMBfJg8f_ZqSAx3u6aPm-TR02dC6bLpMmqSI_jp_ADiJ_qW_27puk=@ethancedwards.com>
Date: Tue, 24 Dec 2024 22:13:21 +0000
From: Ethan Carter Edwards <ethan@...ancedwards.com>
To: "agk@...hat.com" <agk@...hat.com>
Cc: "snitzer@...nel.org" <snitzer@...nel.org>, "dm-devel@...ts.linux.dev" <dm-devel@...ts.linux.dev>, "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>, "kernel-hardening@...ts.openwall.com" <kernel-hardening@...ts.openwall.com>, "linux-hardening@...r.kernel.org" <linux-hardening@...r.kernel.org>, "mpatocka@...hat.com" <mpatocka@...hat.com>
Subject: [PATCH] dm: change kzalloc to kcalloc
Use 2-factor multiplication argument form kcalloc() instead
of instead of the deprecated kzalloc() [1].
[1] https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
Link: https://github.com/KSPP/linux/issues/162
Signed-off-by: Ethan Carter Edwards <ethan@...ancedwards.com>
---
drivers/md/dm-ps-io-affinity.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/md/dm-ps-io-affinity.c b/drivers/md/dm-ps-io-affinity.c
index 461ee6b2044d..716807e511ee 100644
--- a/drivers/md/dm-ps-io-affinity.c
+++ b/drivers/md/dm-ps-io-affinity.c
@@ -116,7 +116,7 @@ static int ioa_create(struct path_selector *ps, unsigned int argc, char **argv)
if (!s)
return -ENOMEM;
- s->path_map = kzalloc(nr_cpu_ids * sizeof(struct path_info *),
+ s->path_map = kcalloc(nr_cpu_ids, sizeof(struct path_info *),
GFP_KERNEL);
if (!s->path_map)
goto free_selector;
--
2.47.1
Powered by blists - more mailing lists