[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <c366fa2f-753c-4123-ac6a-cc28b39f3217@163.com>
Date: Wed, 22 Jan 2025 21:07:04 +0800
From: Jiwei Sun <sjiwei@....com>
To: "Maciej W. Rozycki" <macro@...am.me.uk>
Cc: ilpo.jarvinen@...ux.intel.com, Bjorn Helgaas <bhelgaas@...gle.com>,
linux-pci@...r.kernel.org, linux-kernel@...r.kernel.org, helgaas@...nel.org,
lukas@...ner.de, ahuang12@...ovo.com, sunjw10@...ovo.com,
jiwei.sun.bj@...com, sunjw10@...look.com
Subject: Re: [PATCH v3 1/2] PCI: Fix the wrong reading of register fields
On 1/22/25 20:53, Maciej W. Rozycki wrote:
>> The macro PCIE_LNKCTL2_TLS2SPEED() and PCIE_LNKCAP_SLS2SPEED() just use
>> the link speed field of the registers. However, there are many other
>> different function fields in the Link Control 2 Register or the Link
>> Capabilities Register. If the register value is directly used by the two
>> macros, it may cause getting an error link speed value (PCI_SPEED_UNKNOWN).
>
> The change proposed seems right to me, however...
>
>> diff --git a/drivers/pci/pci.h b/drivers/pci/pci.h
>> index 2e40fc63ba31..c571f5943f3d 100644
>> --- a/drivers/pci/pci.h
>> +++ b/drivers/pci/pci.h
>> @@ -337,12 +337,14 @@ void pci_bus_put(struct pci_bus *bus);
>>
>> #define PCIE_LNKCAP_SLS2SPEED(lnkcap) \
>> ({ \
>> - ((lnkcap) == PCI_EXP_LNKCAP_SLS_64_0GB ? PCIE_SPEED_64_0GT : \
>> - (lnkcap) == PCI_EXP_LNKCAP_SLS_32_0GB ? PCIE_SPEED_32_0GT : \
>> - (lnkcap) == PCI_EXP_LNKCAP_SLS_16_0GB ? PCIE_SPEED_16_0GT : \
>> - (lnkcap) == PCI_EXP_LNKCAP_SLS_8_0GB ? PCIE_SPEED_8_0GT : \
>> - (lnkcap) == PCI_EXP_LNKCAP_SLS_5_0GB ? PCIE_SPEED_5_0GT : \
>> - (lnkcap) == PCI_EXP_LNKCAP_SLS_2_5GB ? PCIE_SPEED_2_5GT : \
>> + u32 __lnkcap = (lnkcap) & PCI_EXP_LNKCAP_SLS; \
>> + \
>> + (__lnkcap == PCI_EXP_LNKCAP_SLS_64_0GB ? PCIE_SPEED_64_0GT : \
>> + __lnkcap == PCI_EXP_LNKCAP_SLS_32_0GB ? PCIE_SPEED_32_0GT : \
>> + __lnkcap == PCI_EXP_LNKCAP_SLS_16_0GB ? PCIE_SPEED_16_0GT : \
>> + __lnkcap == PCI_EXP_LNKCAP_SLS_8_0GB ? PCIE_SPEED_8_0GT : \
>> + __lnkcap == PCI_EXP_LNKCAP_SLS_5_0GB ? PCIE_SPEED_5_0GT : \
>> + __lnkcap == PCI_EXP_LNKCAP_SLS_2_5GB ? PCIE_SPEED_2_5GT : \
>
> ... wouldn't it make sense to give the intermediate variable a meaningful
> name reflecting data it carries, e.g. `lnkcap_sls'?
This is a good idea. I will modify the patch in the v4 patch.
Thanks,
Regards,
Jiwei
Powered by blists - more mailing lists