[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <8d286a6b2a5f481e1eb23466c199a1b05ec81a88.camel@gmail.com>
Date: Thu, 23 Jan 2025 17:34:04 -0800
From: Eduard Zingerman <eddyz87@...il.com>
To: Tao Chen <chen.dylane@...il.com>, ast@...nel.org, daniel@...earbox.net,
andrii@...nel.org, haoluo@...gle.com, jolsa@...nel.org, qmo@...nel.org
Cc: bpf@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH bpf-next v2 1/2] libbpf: Add libbpf_probe_bpf_kfunc API
On Fri, 2025-01-24 at 01:05 +0800, Tao Chen wrote:
[...]
> +int libbpf_probe_bpf_kfunc(enum bpf_prog_type prog_type, int kfunc_id,
> + __s16 off, const void *opts)
^^^
Nit: maybe name this btf_fd?
> +{
In v2 function looks identical to libbpf_probe_bpf_helper,
do we want to copy-paste it or introduce a utility:
static int probe_insn(enum bpf_prog_type prog_type, struct bpf_insn insn,
const char **accepted_msgs)
And call it from both libbpf_probe_bpf_{helper,kfunc}?
> + struct bpf_insn insns[] = {
> + BPF_EXIT_INSN(),
> + BPF_EXIT_INSN(),
> + };
> + const size_t insn_cnt = ARRAY_SIZE(insns);
> + int err;
> + char buf[4096];
> +
> + if (opts)
> + return libbpf_err(-EINVAL);
> +
> + /* Same logic as probe_bpf_helper check */
> + switch (prog_type) {
> + case BPF_PROG_TYPE_TRACING:
> + case BPF_PROG_TYPE_EXT:
> + case BPF_PROG_TYPE_LSM:
> + case BPF_PROG_TYPE_STRUCT_OPS:
> + return -EOPNOTSUPP;
> + default:
> + break;
> + }
> +
> + insns[0].code = BPF_JMP | BPF_CALL;
> + insns[0].src_reg = BPF_PSEUDO_KFUNC_CALL;
> + insns[0].imm = kfunc_id;
> + insns[0].off = off;
> +
> + buf[0] = '\0';
> + err = probe_prog_load(prog_type, insns, insn_cnt, buf, sizeof(buf));
> + if (err < 0)
> + return libbpf_err(err);
> +
> + /* If BPF verifier recognizes BPF kfunc but it's not supported for
> + * given BPF program type, it will emit "calling kernel function
> + * bpf_cpumask_create is not allowed", if the kfunc id is invalid,
> + * it will emit "kernel btf_id 4294967295 is not a function"
> + */
> + if (err == 0 && (strstr(buf, "not allowed") || strstr(buf, "not a function")))
> + return 0;
> +
> + return 1; /* assume supported */
> +}
> +
> int libbpf_probe_bpf_helper(enum bpf_prog_type prog_type, enum bpf_func_id helper_id,
> const void *opts)
> {
Powered by blists - more mailing lists