[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <65b52d7a-c913-4f62-9389-d097c70f4281@arm.com>
Date: Fri, 7 Feb 2025 14:31:25 +0530
From: Dev Jain <dev.jain@....com>
To: Liu Ye <liuye@...inos.cn>, akpm@...ux-foundation.org
Cc: linux-mm@...ck.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] mm/secretmem: Bool type variables should be initialized
with true
On 07/02/25 1:12 pm, Liu Ye wrote:
> The variable secretmem_enable is initialized with 1, which is an integer.
> It would be more appropriate to use true for better readability and
At the cost of messing up the git log. Please don't send trivial
cosmetic changes.
> consistency with the bool type.
>
> Signed-off-by: Liu Ye <liuye@...inos.cn>
> ---
> mm/secretmem.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/mm/secretmem.c b/mm/secretmem.c
> index 1b0a214ee558..2f9442d6633d 100644
> --- a/mm/secretmem.c
> +++ b/mm/secretmem.c
> @@ -35,7 +35,7 @@
> #define SECRETMEM_MODE_MASK (0x0)
> #define SECRETMEM_FLAGS_MASK SECRETMEM_MODE_MASK
>
> -static bool secretmem_enable __ro_after_init = 1;
> +static bool secretmem_enable __ro_after_init = true;
> module_param_named(enable, secretmem_enable, bool, 0400);
> MODULE_PARM_DESC(secretmem_enable,
> "Enable secretmem and memfd_secret(2) system call");
Powered by blists - more mailing lists