[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <fd920faf-a707-4c6d-8c0b-3d59c010da1d@nvidia.com>
Date: Wed, 19 Feb 2025 12:22:23 -0800
From: John Hubbard <jhubbard@...dia.com>
To: Alexandre Courbot <acourbot@...dia.com>, Timur Tabi <ttabi@...dia.com>,
"daniel.almeida@...labora.com" <daniel.almeida@...labora.com>
Cc: "dri-devel@...ts.freedesktop.org" <dri-devel@...ts.freedesktop.org>,
"rust-for-linux@...r.kernel.org" <rust-for-linux@...r.kernel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"nouveau@...ts.freedesktop.org" <nouveau@...ts.freedesktop.org>,
"dakr@...nel.org" <dakr@...nel.org>, "airlied@...il.com"
<airlied@...il.com>, Ben Skeggs <bskeggs@...dia.com>
Subject: Re: [PATCH RFC 1/3] rust: add useful ops for u64
On 2/19/25 4:51 AM, Alexandre Courbot wrote:
> Yes, that looks like the optimal way to do this actually. It also
> doesn't introduce any overhead as the destructuring was doing both
> high_half() and low_half() in sequence, so in some cases it might
> even be more efficient.
>
> I'd just like to find a better naming. high() and low() might be enough?
> Or are there other suggestions?
>
Maybe use "32" instead of "half":
.high_32() / .low_32()
.upper_32() / .lower_32()
thanks,
--
John Hubbard
Powered by blists - more mailing lists