[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAPM=9txmQWO+SHnZhr8zXHCZ=S8CNY=PryRVkWWuHyor-ajU6A@mail.gmail.com>
Date: Thu, 20 Feb 2025 06:23:36 +1000
From: Dave Airlie <airlied@...il.com>
To: John Hubbard <jhubbard@...dia.com>
Cc: Alexandre Courbot <acourbot@...dia.com>, Timur Tabi <ttabi@...dia.com>,
"daniel.almeida@...labora.com" <daniel.almeida@...labora.com>,
"dri-devel@...ts.freedesktop.org" <dri-devel@...ts.freedesktop.org>,
"rust-for-linux@...r.kernel.org" <rust-for-linux@...r.kernel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"nouveau@...ts.freedesktop.org" <nouveau@...ts.freedesktop.org>, "dakr@...nel.org" <dakr@...nel.org>,
Ben Skeggs <bskeggs@...dia.com>
Subject: Re: [PATCH RFC 1/3] rust: add useful ops for u64
On Thu, 20 Feb 2025 at 06:22, John Hubbard <jhubbard@...dia.com> wrote:
>
> On 2/19/25 4:51 AM, Alexandre Courbot wrote:
> > Yes, that looks like the optimal way to do this actually. It also
> > doesn't introduce any overhead as the destructuring was doing both
> > high_half() and low_half() in sequence, so in some cases it might
> > even be more efficient.
> >
> > I'd just like to find a better naming. high() and low() might be enough?
> > Or are there other suggestions?
> >
>
> Maybe use "32" instead of "half":
>
> .high_32() / .low_32()
> .upper_32() / .lower_32()
>
The C code currently does upper_32_bits and lower_32_bits, do we want
to align or diverge here?
Dave.
Powered by blists - more mailing lists