lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <daec1a6fe2a16988b0b0e59942a94ca9@dev.tdt.de>
Date: Wed, 26 Feb 2025 17:51:42 +0100
From: Martin Schiller <ms@....tdt.de>
To: Kory Maincent <kory.maincent@...tlin.com>
Cc: "Russell King (Oracle)" <linux@...linux.org.uk>, andrew@...n.ch,
	hkallweit1@...il.com, davem@...emloft.net, edumazet@...gle.com,
	kuba@...nel.org, pabeni@...hat.com, netdev@...r.kernel.org,
	linux-kernel@...r.kernel.org
Subject: Re: [PATCH net-next] net: sfp: add quirk for FS SFP-10GM-T copper
 SFP+ module

On 2025-02-26 17:27, Kory Maincent wrote:
> On Wed, 26 Feb 2025 16:55:38 +0100
> Martin Schiller <ms@....tdt.de> wrote:
> 
>> On 2025-02-26 16:26, Kory Maincent wrote:
>> > On Wed, 26 Feb 2025 15:50:46 +0100
>> > Martin Schiller <ms@....tdt.de> wrote:
>> >
>> >> On 2025-02-26 15:38, Russell King (Oracle) wrote:
>>  [...]
>>  [...]
>>  [...]
>> >>
>> >> OK, I'll rename it to sfp_fixup_rollball_wait.
>> >
>> > I would prefer sfp_fixup_fs_rollball_wait to keep the name of the
>> > manufacturer.
>> > It can't be a generic fixup as other FSP could have other waiting time
>> > values
>> > like the Turris RTSFP-10G which needs 25s.
>> 
>> I think you're getting two things mixed up.
>> The phy still has 25 seconds to wake up. With sfp_fixup_rollball_wait
>> there simply is an additional 4s wait at the beginning before we start
>> searching for a phy.
> 
> Indeed you are right, I was looking in older Linux sources, sorry.
> Still, the additional 4s wait seems relevant only for FS SFP, so it 
> should
> be included in the function naming to avoid confusion.
> 

You may be right for the moment. But perhaps there will soon be SFP
modules from other manufacturers that also need this quirk.

There is also the function sfp_fixup_rollball_cc, which is currently
only used for modules with vendor string “OEM”. However, the function is
not called sfp_fixup_oem_rollball_cc.

Regards,
Martin

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ