[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID:
<DB9PR04MB8429BF55DF50CCF7E9AB827292D52@DB9PR04MB8429.eurprd04.prod.outlook.com>
Date: Fri, 7 Mar 2025 08:02:10 +0000
From: Sherry Sun <sherry.sun@....com>
To: Jiri Slaby <jirislaby@...nel.org>, "gregkh@...uxfoundation.org"
<gregkh@...uxfoundation.org>
CC: "linux-serial@...r.kernel.org" <linux-serial@...r.kernel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"imx@...ts.linux.dev" <imx@...ts.linux.dev>, Shenwei Wang
<shenwei.wang@....com>
Subject: RE: [PATCH 1/2] tty: serial: fsl_lpuart: Use u32 for register
variables
> -----Original Message-----
> From: Jiri Slaby <jirislaby@...nel.org>
> Sent: Friday, March 7, 2025 3:26 PM
> To: Sherry Sun <sherry.sun@....com>; gregkh@...uxfoundation.org
> Cc: linux-serial@...r.kernel.org; linux-kernel@...r.kernel.org;
> imx@...ts.linux.dev; Shenwei Wang <shenwei.wang@....com>
> Subject: Re: [PATCH 1/2] tty: serial: fsl_lpuart: Use u32 for register variables
>
> On 07. 03. 25, 3:25, Sherry Sun wrote:
> > Use u32 rather than unsigned long for register variables for clarity
> > and consistency.
> >
> > Signed-off-by: Sherry Sun <sherry.sun@....com>
> > ---
> > drivers/tty/serial/fsl_lpuart.c | 54 ++++++++++++++++-----------------
> > 1 file changed, 27 insertions(+), 27 deletions(-)
> >
> > diff --git a/drivers/tty/serial/fsl_lpuart.c
> > b/drivers/tty/serial/fsl_lpuart.c index 4dc2f3e2b8e0..888d744494d6
> > 100644
> > --- a/drivers/tty/serial/fsl_lpuart.c
> > +++ b/drivers/tty/serial/fsl_lpuart.c
> > @@ -450,7 +450,7 @@ static void lpuart_stop_tx(struct uart_port *port)
> >
> > static void lpuart32_stop_tx(struct uart_port *port)
> > {
> > - unsigned long temp;
> > + u32 temp;
>
> This patch is fine per se. But could you also rename these temps to
> something sane? (In a separate patch.) Like ctrl in this case.
>
Hi Jiri,
Sure, will make another patch to clean up these temp variable names.
Best Regards
Sherry
Powered by blists - more mailing lists