[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <7945ffca-6c2c-4baf-89e7-688681db29ca@amd.com>
Date: Mon, 10 Mar 2025 09:07:10 -0500
From: "Moger, Babu" <babu.moger@....com>
To: James Morse <james.morse@....com>, x86@...nel.org,
linux-kernel@...r.kernel.org
Cc: Reinette Chatre <reinette.chatre@...el.com>,
Thomas Gleixner <tglx@...utronix.de>, Ingo Molnar <mingo@...hat.com>,
Borislav Petkov <bp@...en8.de>, H Peter Anvin <hpa@...or.com>,
shameerali.kolothum.thodi@...wei.com,
D Scott Phillips OS <scott@...amperecomputing.com>,
carl@...amperecomputing.com, lcherian@...vell.com,
bobo.shaobowang@...wei.com, tan.shaopeng@...itsu.com,
baolin.wang@...ux.alibaba.com, Jamie Iles <quic_jiles@...cinc.com>,
Xin Hao <xhao@...ux.alibaba.com>, peternewman@...gle.com,
dfustini@...libre.com, amitsinght@...vell.com,
David Hildenbrand <david@...hat.com>, Rex Nie <rex.nie@...uarmicro.com>,
Dave Martin <dave.martin@....com>, Koba Ko <kobak@...dia.com>,
Shanker Donthineni <sdonthineni@...dia.com>, fenghuay@...dia.com
Subject: Re: [PATCH v7 00/49] x86/resctrl: Move the resctrl filesystem code to
/fs/resctrl
On 2/28/25 13:58, James Morse wrote:
> Changes since v6?:
> * All the excitement is in patch 37, turns out there are two rmdir() paths
> that don't join up.
> The last eight patches are new:
> * The python script has been replaced with the patch that it generates, see
> the bare branch below if you want to regenerate it.
> * There have been comments on the followup to the generated patch, those are
> included here - I suggest they be squashed into the generated patch.
> * This version includes some checkpatch linting from Dave.
>
> ---
> This series renames functions and moves code around. With the
> exception of invalid configurations for the configurable-events, there should
> be no changes in behaviour caused by this series. It is now possible for
> throttle_mode to report 'undefined', but no known platform will do this.
>
> The driving pattern is to make things like struct rdtgroup private to resctrl.
> Features like pseudo-lock aren't going to work on arm64, the ability to disable
> it at compile time is added.
>
> After this, I can start posting the MPAM driver to make use of resctrl on arm64.
> (What's MPAM? See the cover letter of the first series. [1])
>
> This series is based on v6.14-rc3 and can be retrieved from:
> https://git.kernel.org/pub/scm/linux/kernel/git/morse/linux.git mpam/move_to_fs/v7
> or for those who want to regnerate the patch that moves all the code:
> https://git.kernel.org/pub/scm/linux/kernel/git/morse/linux.git mpam/move_to_fs/v7_bare
>
>
> As ever - bugs welcome,
> Thanks,
>
> James
>
> [v6] https://lore.kernel.org/lkml/20250207181823.6378-1-james.morse@arm.com/
> [v5] https://lore.kernel.org/r/20241004180347.19985-1-james.morse@arm.com
> [v4] https://lore.kernel.org/all/20240802172853.22529-1-james.morse@arm.com/
> [v3] https://lore.kernel.org/r/20240614150033.10454-1-james.morse@arm.com
> [v2] https://lore.kernel.org/r/20240426150537.8094-1-Dave.Martin@arm.com
> [v1] https://lore.kernel.org/r/20240321165106.31602-1-james.morse@arm.com
> [1] https://lore.kernel.org/lkml/20201030161120.227225-1-james.morse@arm.com/
>
> Amit Singh Tomar (1):
> x86/resctrl: Remove the limit on the number of CLOSID
>
> Dave Martin (3):
> x86/resctrl: Squelch whitespace anomalies in resctrl core code
> x86/resctrl: Prefer alloc(sizeof(*foo)) idiom in rdt_init_fs_context()
> x86/resctrl: Relax some asm #includes
>
> James Morse (45):
> x86/resctrl: Fix allocation of cleanest CLOSID on platforms with no
> monitors
> x86/resctrl: Add a helper to avoid reaching into the arch code
> resource list
> x86/resctrl: Remove fflags from struct rdt_resource
> x86/resctrl: Use schema type to determine how to parse schema values
> x86/resctrl: Use schema type to determine the schema format string
> x86/resctrl: Remove data_width and the tabular format
> x86/resctrl: Add max_bw to struct resctrl_membw
> x86/resctrl: Generate default_ctrl instead of sharing it
> x86/resctrl: Add helper for setting CPU default properties
> x86/resctrl: Remove rdtgroup from update_cpu_closid_rmid()
> x86/resctrl: Expose resctrl fs's init function to the rest of the
> kernel
> x86/resctrl: Move rdt_find_domain() to be visible to arch and fs code
> x86/resctrl: Move resctrl types to a separate header
> x86/resctrl: Add an arch helper to reset one resource
> x86/resctrl: Move monitor exit work to a resctrl exit call
> x86/resctrl: Move monitor init work to a resctrl init call
> x86/resctrl: Rewrite and move the for_each_*_rdt_resource() walkers
> x86/resctrl: Move the is_mbm_*_enabled() helpers to asm/resctrl.h
> x86/resctrl: Add resctrl_arch_is_evt_configurable() to abstract BMEC
> x86/resctrl: Change mon_event_config_{read,write}() to be arch helpers
> x86/resctrl: Move mba_mbps_default_event init to filesystem code
> x86/resctrl: Move mbm_cfg_mask to struct rdt_resource
> x86/resctrl: Add resctrl_arch_ prefix to pseudo lock functions
> x86/resctrl: Allow an architecture to disable pseudo lock
> x86/resctrl: Make prefetch_disable_bits belong to the arch code
> x86/resctrl: Make resctrl_arch_pseudo_lock_fn() take a plr
> x86/resctrl: Move RFTYPE flags to be managed by resctrl
> x86/resctrl: Handle throttle_mode for SMBA resources
> x86/resctrl: Move get_config_index() to a header
> x86/resctrl: Move get_{mon,ctrl}_domain_from_cpu() to live with their
> callers
> x86/resctrl: Rename resctrl_sched_in() to begin with "resctrl_arch_"
> x86/resctrl: resctrl_exit() teardown resctrl but leave the mount point
> x86/resctrl: Drop __init/__exit on assorted symbols
> x86/resctrl: Move is_mba_sc() out of core.c
> x86/resctrl: Add end-marker to the resctrl_event_id enum
> x86/resctrl: Expand the width of dom_id by replacing mon_data_bits
> x86/resctrl: Remove a newline to avoid confusing the code move script
> x86/resctrl: Split trace.h
> fs/resctrl: Add boiler plate for external resctrl code
> x86/resctrl: Move the filesystem bits to headers visible to fs/resctrl
> x86,fs/resctrl: Move the resctrl filesystem code to live in
> /fs/resctrl
> x86,fs/resctrl: Remove duplicated trace header files
> fs/resctrl: Remove unnecessary includes
> fs/resctrl: Change internal.h's header guard macros
> x86,fs/resctrl: Move resctrl.rst to live under
> Documentation/filesystems
>
> Documentation/arch/x86/index.rst | 1 -
> Documentation/filesystems/index.rst | 1 +
> .../{arch/x86 => filesystems}/resctrl.rst | 0
> MAINTAINERS | 4 +-
> arch/Kconfig | 8 +
> arch/x86/Kconfig | 6 +-
> arch/x86/include/asm/resctrl.h | 43 +-
> arch/x86/kernel/cpu/resctrl/Makefile | 8 +-
> arch/x86/kernel/cpu/resctrl/core.c | 214 +-
> arch/x86/kernel/cpu/resctrl/ctrlmondata.c | 606 +--
> arch/x86/kernel/cpu/resctrl/internal.h | 504 +-
> arch/x86/kernel/cpu/resctrl/monitor.c | 863 +---
> arch/x86/kernel/cpu/resctrl/pseudo_lock.c | 1120 +----
> .../resctrl/{trace.h => pseudo_lock_trace.h} | 26 +-
> arch/x86/kernel/cpu/resctrl/rdtgroup.c | 4031 +--------------
> arch/x86/kernel/process_32.c | 2 +-
> arch/x86/kernel/process_64.c | 2 +-
> fs/Kconfig | 1 +
> fs/Makefile | 1 +
> fs/resctrl/Kconfig | 39 +
> fs/resctrl/Makefile | 6 +
> fs/resctrl/ctrlmondata.c | 660 +++
> fs/resctrl/internal.h | 435 ++
> fs/resctrl/monitor.c | 933 ++++
> fs/resctrl/monitor_trace.h | 33 +
> fs/resctrl/pseudo_lock.c | 1104 +++++
> fs/resctrl/rdtgroup.c | 4329 +++++++++++++++++
> include/linux/resctrl.h | 216 +-
> include/linux/resctrl_types.h | 59 +
> 29 files changed, 7992 insertions(+), 7263 deletions(-)
> rename Documentation/{arch/x86 => filesystems}/resctrl.rst (100%)
> rename arch/x86/kernel/cpu/resctrl/{trace.h => pseudo_lock_trace.h} (56%)
> create mode 100644 fs/resctrl/Kconfig
> create mode 100644 fs/resctrl/Makefile
> create mode 100644 fs/resctrl/ctrlmondata.c
> create mode 100644 fs/resctrl/internal.h
> create mode 100644 fs/resctrl/monitor.c
> create mode 100644 fs/resctrl/monitor_trace.h
> create mode 100644 fs/resctrl/pseudo_lock.c
> create mode 100644 fs/resctrl/rdtgroup.c
> create mode 100644 include/linux/resctrl_types.h
>
Ran tests on couple of AMD systems. Everything looks good.
Tested-by: Babu Moger <babu.moger@....com>
--
Thanks
Babu Moger
Powered by blists - more mailing lists