[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <odaup4s2j7uzjmucdsio2y5umfwwtmn5l6rotu3xwjatgwsahn@sgfpdv56mny4>
Date: Fri, 14 Mar 2025 12:56:00 +0200
From: Dmitry Baryshkov <dmitry.baryshkov@....qualcomm.com>
To: Ayushi Makhija <quic_amakhija@...cinc.com>
Cc: Dmitry Baryshkov <dbaryshkov@...il.com>,
Dmitry Baryshkov <lumag@...nel.org>, linux-arm-msm@...r.kernel.org,
dri-devel@...ts.freedesktop.org, freedreno@...ts.freedesktop.org,
devicetree@...r.kernel.org, linux-kernel@...r.kernel.org,
robdclark@...il.com, dmitry.baryshkov@...aro.org, sean@...rly.run,
marijn.suijten@...ainline.org, andersson@...nel.org, robh@...nel.org,
robh+dt@...nel.org, krzk+dt@...nel.org, konradybcio@...nel.org,
conor+dt@...nel.org, andrzej.hajda@...el.com,
neil.armstrong@...aro.org, rfoss@...nel.org,
Laurent.pinchart@...asonboard.com, jonas@...boo.se,
jernej.skrabec@...il.com, quic_abhinavk@...cinc.com,
quic_rajeevny@...cinc.com, quic_vproddut@...cinc.com,
quic_jesszhan@...cinc.com
Subject: Re: [PATCH v2 09/10] drm/bridge: anx7625: update bridge_ops and sink
detect logic
On Thu, Mar 13, 2025 at 12:14:04PM +0530, Ayushi Makhija wrote:
>
>
> On 3/12/2025 4:33 PM, Dmitry Baryshkov wrote:
> > On Wed, 12 Mar 2025 at 11:47, Ayushi Makhija <quic_amakhija@...cinc.com> wrote:
> >>
> >> On 3/11/2025 9:11 PM, Dmitry Baryshkov wrote:
> >>> On Tue, Mar 11, 2025 at 05:54:44PM +0530, Ayushi Makhija wrote:
> >>>> The anx7625_link_bridge() checks if a device is not a panel
> >>>> bridge and add DRM_BRIDGE_OP_HPD and DRM_BRIDGE_OP_DETECT to
> >>>> the bridge operations. However, on port 1 of the anx7625
> >>>> bridge, any device added is always treated as a panel
> >>>> bridge, preventing connector_detect function from being
> >>>> called. To resolve this, instead of just checking if it is a
> >>>> panel bridge, verify the type of panel bridge
> >>>> whether it is a DisplayPort or eDP panel. If the panel
> >>>> bridge is not of the eDP type, add DRM_BRIDGE_OP_HPD and
> >>>> DRM_BRIDGE_OP_DETECT to the bridge operations.
> >>>
> >>> Are/were there any devices using anx7625, eDP panel _and_ not using the
> >>> AUX bus? It would be better to use the precence of the 'aux' node to
> >>> determine whether it is an eDP or a DP configuration.
> >>>
> >>>>
> >>>> In the anx7625_sink_detect(), the device is checked to see
> >>>> if it is a panel bridge, and it always sends a "connected"
> >>>> status to the connector. When adding the DP port on port 1 of the
> >>>> anx7625, it incorrectly treats it as a panel bridge and sends an
> >>>> always "connected" status. Instead of checking the status on the
> >>>> panel bridge, it's better to check the hpd_status for connectors
> >>>> like DisplayPort. This way, it verifies the hpd_status variable
> >>>> before sending the status to the connector.
> >>>>
> >>>> Signed-off-by: Ayushi Makhija <quic_amakhija@...cinc.com>
> >>>> ---
> >>>> drivers/gpu/drm/bridge/analogix/anx7625.c | 10 ++++------
> >>>> 1 file changed, 4 insertions(+), 6 deletions(-)
> >>>>
> >>>> diff --git a/drivers/gpu/drm/bridge/analogix/anx7625.c b/drivers/gpu/drm/bridge/analogix/anx7625.c
> >>>> index 764da1c1dc11..ad99ad19653f 100644
> >>>> --- a/drivers/gpu/drm/bridge/analogix/anx7625.c
> >>>> +++ b/drivers/gpu/drm/bridge/analogix/anx7625.c
> >>>> @@ -1814,9 +1814,6 @@ static enum drm_connector_status anx7625_sink_detect(struct anx7625_data *ctx)
> >>>>
> >>>> DRM_DEV_DEBUG_DRIVER(dev, "sink detect\n");
> >>>>
> >>>> - if (ctx->pdata.panel_bridge)
> >>>> - return connector_status_connected;
> >>>> -
> >>>> return ctx->hpd_status ? connector_status_connected :
> >>>> connector_status_disconnected;
> >>>> }
> >>>> @@ -2608,9 +2605,10 @@ static int anx7625_link_bridge(struct drm_dp_aux *aux)
> >>>> platform->bridge.of_node = dev->of_node;
> >>>> if (!anx7625_of_panel_on_aux_bus(dev))
> >>>> platform->bridge.ops |= DRM_BRIDGE_OP_EDID;
> >>>> - if (!platform->pdata.panel_bridge)
> >>>> - platform->bridge.ops |= DRM_BRIDGE_OP_HPD |
> >>>> - DRM_BRIDGE_OP_DETECT;
> >>>> + if (!platform->pdata.panel_bridge ||
> >>>> + platform->pdata.panel_bridge->type != DRM_MODE_CONNECTOR_eDP) {
> >>>> + platform->bridge.ops |= DRM_BRIDGE_OP_HPD | DRM_BRIDGE_OP_DETECT;
> >>>> + }
> >>
> >> Hi Dmitry,
> >>
> >> Thanks, for the review.
> >>
> >> Yes, it is better to check the presence of the 'aux' node for eDP or DP configuration.
> >> Will change it in next patch.
> >>
> >> - if (!platform->pdata.panel_bridge)
> >> - platform->bridge.ops |= DRM_BRIDGE_OP_HPD |
> >> - DRM_BRIDGE_OP_DETECT;
> >> + if (!platform->pdata.panel_bridge || !anx7625_of_panel_on_aux_bus(dev)) {
> >
> > This is incorrect, if I'm not mistaken, please doublecheck it. I'd
> > suggest following msm_dp_display_get_connector_type() (feel free to
> > extract that to a helper function).
> >
>
> Hi Dmirty,
>
> Thanks, for the review.
>
> If we see definition of anx7625_of_panel_on_aux_bus() it is doing the same
> thing as msm_dp_display_get_connector_type().
Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov@....qualcomm.com>
Please excuse my confusion.
>
> static bool anx7625_of_panel_on_aux_bus(struct device *dev)
> {
> struct device_node *bus, *panel;
>
> bus = of_get_child_by_name(dev->of_node, "aux-bus");
>
> // if aux-bus is not there it will return the false.
> if (!bus)
> return false;
>
> panel = of_get_child_by_name(bus, "panel");
> of_node_put(bus);
>
> // if panel is not there it will return the false.
> if (!panel)
> return false;
> of_node_put(panel);
>
> return true;
> }
>
> Above function will return true in case of eDP and false in case of DP.
> So we can use anx7625_of_panel_on_aux_bus() to check whether it
> is DP or eDP configuration based on aux.
>
> I don't think so we need extract msm_dp_display_get_connector_type() to check the eDP or DP configuration based on aux.
> Let me know, if I am missing anything.
>
> Thanks,
> Ayushi
>
--
With best wishes
Dmitry
Powered by blists - more mailing lists