[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250314123058.GZ5880@noisy.programming.kicks-ass.net>
Date: Fri, 14 Mar 2025 13:30:58 +0100
From: Peter Zijlstra <peterz@...radead.org>
To: Sebastian Andrzej Siewior <bigeasy@...utronix.de>
Cc: linux-kernel@...r.kernel.org,
André Almeida <andrealmeid@...lia.com>,
Darren Hart <dvhart@...radead.org>,
Davidlohr Bueso <dave@...olabs.net>, Ingo Molnar <mingo@...hat.com>,
Juri Lelli <juri.lelli@...hat.com>,
Thomas Gleixner <tglx@...utronix.de>,
Valentin Schneider <vschneid@...hat.com>,
Waiman Long <longman@...hat.com>,
Paul McKenney <paulmck@...nel.org>
Subject: Re: [PATCH v10 00/21] futex: Add support task local hash maps,
FUTEX2_NUMA and FUTEX2_MPOL
On Fri, Mar 14, 2025 at 01:00:57PM +0100, Sebastian Andrzej Siewior wrote:
> On 2025-03-14 12:41:02 [+0100], Peter Zijlstra wrote:
> > On Fri, Mar 14, 2025 at 12:28:08PM +0100, Sebastian Andrzej Siewior wrote:
> > > On 2025-03-14 11:58:56 [+0100], Peter Zijlstra wrote:
> > > > On Wed, Mar 12, 2025 at 04:18:48PM +0100, Sebastian Andrzej Siewior wrote:
> > > >
> > > > > @@ -1591,7 +1597,8 @@ static int futex_hash_allocate(unsigned int hash_slots, bool custom)
> > > > > struct futex_private_hash *free __free(kvfree) = NULL;
> > > > > struct futex_private_hash *cur, *new;
> > > > >
> > > > > - cur = mm->futex_phash;
> > > > > + cur = rcu_dereference_protected(mm->futex_phash,
> > > > > + lockdep_is_held(&mm->futex_hash_lock));
> > > > > new = mm->futex_phash_new;
> > > > > mm->futex_phash_new = NULL;
> > > > >
> > > >
> > > > Same thing again, this makes no sense.
> > >
> > > With "mm->futex_phash" sparse complains about direct RCU access.
> >
> > Yeah, but sparse is stupid.
>
> I though we like sparse.
I always ignore it, too much noise.
> > > This makes it obvious that you can access it, it won't change as long
> > > as you have the lock.
> >
> > It's just plain confusing. rcu_dereference() says you care about the
> > load being single copy atomic and the data dependency, we don't.
> >
> > If we just want to shut up sparse; can't we write it like:
> >
> > cur = unrcu_pointer(mm->futex_phash);
> >
> > ?
>
> But isn't rcu_dereference_protected() doing exactly this? It only
> verifies that lockdep_is_held() thingy and it performs a plain read, no
> READ_ONCE() or anything. And the reader understands why it is safe to
> access the pointer as-is.
Urgh, so we have a rcu_dereference_*() function that does not in fact
imply rcu_dereference() ? WTF kind of insane naming it that?
But yes, it appears you are correct :-(
Powered by blists - more mailing lists