[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Z9w-10St-WYpSnKC@kernel.org>
Date: Thu, 20 Mar 2025 18:14:15 +0200
From: Jarkko Sakkinen <jarkko@...nel.org>
To: David Howells <dhowells@...hat.com>
Cc: Kees Cook <kees@...nel.org>, Oleg Nesterov <oleg@...hat.com>,
Greg KH <gregkh@...uxfoundation.org>,
Josh Drake <josh@...phoslabs.com>,
Suraj Sonawane <surajsonawane0215@...il.com>,
keyrings@...r.kernel.org, linux-security-module@...r.kernel.org,
security@...nel.org, stable@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH v2] keys: Fix UAF in key_put()
On Wed, Mar 19, 2025 at 03:57:46PM +0000, David Howells wrote:
>
> Once a key's reference count has been reduced to 0, the garbage collector
> thread may destroy it at any time and so key_put() is not allowed to touch
> the key after that point. The most key_put() is normally allowed to do is
> to touch key_gc_work as that's a static global variable.
>
> However, in an effort to speed up the reclamation of quota, this is now
> done in key_put() once the key's usage is reduced to 0 - but now the code
> is looking at the key after the deadline, which is forbidden.
>
> Fix this by using a flag to indicate that a key can be gc'd now rather than
> looking at the key's refcount in the garbage collector.
>
> Fixes: 9578e327b2b4 ("keys: update key quotas in key_put()")
> Reported-by: syzbot+6105ffc1ded71d194d6d@...kaller.appspotmail.com
> Signed-off-by: David Howells <dhowells@...hat.com>
> Tested-by: syzbot+6105ffc1ded71d194d6d@...kaller.appspotmail.com
> cc: Jarkko Sakkinen <jarkko@...nel.org>
> cc: Oleg Nesterov <oleg@...hat.com>
> cc: Kees Cook <kees@...nel.org>
> cc: Hillf Danton <hdanton@...a.com>,
> cc: keyrings@...r.kernel.org
> Cc: stable@...r.kernel.org # v6.10+
> ---
> include/linux/key.h | 1 +
> security/keys/gc.c | 4 +++-
> security/keys/key.c | 2 ++
> 3 files changed, 6 insertions(+), 1 deletion(-)
>
> diff --git a/include/linux/key.h b/include/linux/key.h
> index 074dca3222b9..ba05de8579ec 100644
> --- a/include/linux/key.h
> +++ b/include/linux/key.h
> @@ -236,6 +236,7 @@ struct key {
> #define KEY_FLAG_ROOT_CAN_INVAL 7 /* set if key can be invalidated by root without permission */
> #define KEY_FLAG_KEEP 8 /* set if key should not be removed */
> #define KEY_FLAG_UID_KEYRING 9 /* set if key is a user or user session keyring */
> +#define KEY_FLAG_FINAL_PUT 10 /* set if final put has happened on key */
>
> /* the key type and key description string
> * - the desc is used to match a key against search criteria
> diff --git a/security/keys/gc.c b/security/keys/gc.c
> index 7d687b0962b1..f27223ea4578 100644
> --- a/security/keys/gc.c
> +++ b/security/keys/gc.c
> @@ -218,8 +218,10 @@ static void key_garbage_collector(struct work_struct *work)
> key = rb_entry(cursor, struct key, serial_node);
> cursor = rb_next(cursor);
>
> - if (refcount_read(&key->usage) == 0)
> + if (test_bit(KEY_FLAG_FINAL_PUT, &key->flags)) {
> + smp_mb(); /* Clobber key->user after FINAL_PUT seen. */
test_bit() is already atomic.
https://docs.kernel.org/core-api/wrappers/atomic_bitops.html
> goto found_unreferenced_key;
> + }
>
> if (unlikely(gc_state & KEY_GC_REAPING_DEAD_1)) {
> if (key->type == key_gc_dead_keytype) {
> diff --git a/security/keys/key.c b/security/keys/key.c
> index 3d7d185019d3..7198cd2ac3a3 100644
> --- a/security/keys/key.c
> +++ b/security/keys/key.c
> @@ -658,6 +658,8 @@ void key_put(struct key *key)
> key->user->qnbytes -= key->quotalen;
> spin_unlock_irqrestore(&key->user->lock, flags);
> }
> + smp_mb(); /* key->user before FINAL_PUT set. */
> + set_bit(KEY_FLAG_FINAL_PUT, &key->flags);
Ditto.
Nit: I'm just thinking should the name imply more like that "now
key_put() is actually done". E.g., even something like KEY_FLAG_PUT_DONE
would be more self-descriptive.
> schedule_work(&key_gc_work);
> }
> }
>
>
BR, Jarkko
Powered by blists - more mailing lists