[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ef73e566-5a1d-961-73b1-839579811ba5@inria.fr>
Date: Mon, 31 Mar 2025 21:05:46 +0200 (CEST)
From: Julia Lawall <julia.lawall@...ia.fr>
To: Erick Karanja <karanja99erick@...il.com>
cc: gregkh@...uxfoundation.org, outreachy@...ts.linux.dev,
philipp.g.hortmann@...il.com, linux-staging@...ts.linux.dev,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH 2/5] staging: rtl8723bs: replace kmalloc + memset with
kzalloc
On Mon, 31 Mar 2025, Erick Karanja wrote:
> Replace a call to kmalloc followed by memset with a single call to
> kzalloc, which both allocates memory and zeroes it in one step.
>
> This change improves readability and reduces redundant code.
>
> Signed-off-by: Erick Karanja <karanja99erick@...il.com>
> ---
> drivers/staging/rtl8723bs/os_dep/osdep_service.c | 7 +------
> 1 file changed, 1 insertion(+), 6 deletions(-)
>
> diff --git a/drivers/staging/rtl8723bs/os_dep/osdep_service.c b/drivers/staging/rtl8723bs/os_dep/osdep_service.c
> index a00f9f0c85c5..be46132a533a 100644
> --- a/drivers/staging/rtl8723bs/os_dep/osdep_service.c
> +++ b/drivers/staging/rtl8723bs/os_dep/osdep_service.c
> @@ -24,12 +24,7 @@ void *_rtw_malloc(u32 sz)
>
> void *_rtw_zmalloc(u32 sz)
> {
> - void *pbuf = _rtw_malloc(sz);
> -
> - if (pbuf)
> - memset(pbuf, 0, sz);
> -
> - return pbuf;
> + return kzalloc(sz, in_interrupt() ? GFP_ATOMIC : GFP_KERNEL);
> }
So _rtw_malloc calls kmalloc?
How about gettind rid of both _rtw_malloc and _rtw_zmalloc and calling
kmalloc and kzalloc instead? You should try to figure out if GFP_ATOMIC
or GFP_KERNEL should be used based on the context. If you search for
those constants, you should be able to find some explanations about when
they should be used.
julia
>
> inline struct sk_buff *_rtw_skb_alloc(u32 sz)
> --
> 2.43.0
>
>
>
Powered by blists - more mailing lists