lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <gkq5rxrawtcqsnru7jsfkrxfzubbqq3rbd6fdulmqtdjmitbwk@5jj6l5aafh7x>
Date: Sun, 6 Apr 2025 01:03:54 +0200
From: Sebastian Reichel <sebastian.reichel@...labora.com>
To: shao.mingyin@....com.cn
Cc: vkoul@...nel.org, robert.marko@...tura.hr, kishon@...nel.org, 
	wens@...e.org, jernej.skrabec@...il.com, samuel@...lland.org, 
	zhang.enpei@....com.cn, linux-phy@...ts.infradead.org, 
	linux-arm-kernel@...ts.infradead.org, linux-sunxi@...ts.linux.dev, linux-kernel@...r.kernel.org, 
	luka.perkov@...tura.hr, linux-arm-msm@...r.kernel.org, heiko@...ech.de, 
	linux-rockchip@...ts.infradead.org, yang.yang29@....com.cn, xu.xin16@....com.cn, 
	ye.xingchen@....com.cn
Subject: Re: [PATCH linux-next 5/5] phy: rockchip: phy-rockchip-typec: Use dev_err_probe()

Hi,

On Wed, Apr 02, 2025 at 07:45:42PM +0800, shao.mingyin@....com.cn wrote:
> From: Zhang Enpei <zhang.enpei@....com.cn>
> 
> Replace the open-code with dev_err_probe() to simplify the code.
> 
> Signed-off-by: Zhang Enpei <zhang.enpei@....com.cn>
> Signed-off-by: Shao Mingyin <shao.mingyin@....com.cn>
> ---
>  drivers/phy/rockchip/phy-rockchip-typec.c | 8 +++-----
>  1 file changed, 3 insertions(+), 5 deletions(-)
> 
> diff --git a/drivers/phy/rockchip/phy-rockchip-typec.c b/drivers/phy/rockchip/phy-rockchip-typec.c
> index d9701b6106d5..94d1e6ead1a7 100644
> --- a/drivers/phy/rockchip/phy-rockchip-typec.c
> +++ b/drivers/phy/rockchip/phy-rockchip-typec.c
> @@ -1151,11 +1151,9 @@ static int rockchip_typec_phy_probe(struct platform_device *pdev)
>  	if (IS_ERR(tcphy->extcon)) {
>  		if (PTR_ERR(tcphy->extcon) == -ENODEV) {
>  			tcphy->extcon = NULL;
> -		} else {
> -			if (PTR_ERR(tcphy->extcon) != -EPROBE_DEFER)
> -				dev_err(dev, "Invalid or missing extcon\n");
> -			return PTR_ERR(tcphy->extcon);
> -		}
> +		} else
> +			return dev_err_probe(dev, PTR_ERR(tcphy->extcon),
> +					     "Invalid or missing extcon\n");

You should also remove the { } for the normal if clause. Otherwise

Reviewed-by: Sebastian Reichel <sebastian.reichel@...labora.com>

But you might want to throw in an extra patch updating the error
message. -ENODEV is covered explicitly, so it's not "missing". I
suggest "Failed to get extcon".

Greetings,

-- Sebastian

>  	}
> 
>  	pm_runtime_enable(dev);
> -- 
> 2.25.1
> 

Download attachment "signature.asc" of type "application/pgp-signature" (834 bytes)

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ