[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <pat3f5nc57uo6p7vwmlrky6ezxhtn3qldmx3falmc4hv5beyyj@r2jfmuxtx5pi>
Date: Sat, 19 Apr 2025 15:36:05 +0800
From: Longbin Li <looong.bin@...il.com>
To: Chen Wang <unicorn_wang@...look.com>
Cc: Uwe Kleine-König <ukleinek@...nel.org>,
Rob Herring <robh@...nel.org>, Krzysztof Kozlowski <krzk+dt@...nel.org>,
Conor Dooley <conor+dt@...nel.org>, Inochi Amaoto <inochiama@...il.com>,
Paul Walmsley <paul.walmsley@...ive.com>, Palmer Dabbelt <palmer@...belt.com>,
Albert Ou <aou@...s.berkeley.edu>, Alexandre Ghiti <alex@...ti.fr>, linux-pwm@...r.kernel.org,
devicetree@...r.kernel.org, sophgo@...ts.linux.dev, linux-kernel@...r.kernel.org,
linux-riscv@...ts.infradead.org
Subject: Re: [PATCH v2 3/3] pwm: sophgo: add driver for SG2044
On Sat, Apr 19, 2025 at 09:24:23AM +0800, Chen Wang wrote:
>
> On 2025/4/18 10:29, Longbin Li wrote:
> > Add PWM controller for SG2044 on base of SG2042.
> >
> > Signed-off-by: Longbin Li <looong.bin@...il.com>
> > ---
> > drivers/pwm/pwm-sophgo-sg2042.c | 89 ++++++++++++++++++++++++++++++++-
> > 1 file changed, 87 insertions(+), 2 deletions(-)
> >
> > diff --git a/drivers/pwm/pwm-sophgo-sg2042.c b/drivers/pwm/pwm-sophgo-sg2042.c
> > index 23a83843ba53..26147ec596c9 100644
> > --- a/drivers/pwm/pwm-sophgo-sg2042.c
> > +++ b/drivers/pwm/pwm-sophgo-sg2042.c
> > @@ -13,6 +13,9 @@
> > * the running period.
> > * - When PERIOD and HLPERIOD is set to 0, the PWM wave output will
> > * be stopped and the output is pulled to high.
> > + * - SG2044 support polarity while SG2042 does not. When PWMSTART is
> > + * false, POLARITY being NORMAL will make output being low,
> > + * POLARITY being INVERSED will make output being high.
> > * See the datasheet [1] for more details.
> > * [1]:https://github.com/sophgo/sophgo-doc/tree/main/SG2042/TRM
> > */
> > @@ -26,6 +29,10 @@
> > #include <linux/pwm.h>
> > #include <linux/reset.h>
> >
> > +#define SG2044_REG_POLARITY 0x40
> > +#define SG2044_REG_PWMSTART 0x44
> > +#define SG2044_REG_PWM_OE 0xD0
>
> SG2044_REG_xxx, the prefix looks inconsistent with
> SG2042_PWM_HLPERIOD/SG2042_PWM_PERIOD. Can it be unified?
>
> The others look fine.
>
> Reviewed-by: Chen Wang <unicorn_wang@...look.com>
>
> [......]
>
>
I will rename it to unify, thanks.
Best regards,
Longbin Li
Powered by blists - more mailing lists