[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <d0353f6c-8bab-4178-8bed-0ad6157fe351@baylibre.com>
Date: Tue, 6 May 2025 12:11:51 -0500
From: David Lechner <dlechner@...libre.com>
To: Chelsy Ratnawat <chelsyratnawat2001@...il.com>, jikos@...nel.org,
bentiss@...nel.org, jic23@...nel.org, srinivas.pandruvada@...ux.intel.com
Cc: linux-input@...r.kernel.org, linux-iio@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH] HID: sensor-hub: Fix typo and improve documentation
On 5/6/25 11:35 AM, Chelsy Ratnawat wrote:
> Includes the following corrections -
> - Changed Measurment -> Measurement
> - Changed clode -> close
> - Gyro -> gyro
>
> Signed-off-by: Chelsy Ratnawat <chelsyratnawat2001@...il.com>
> ---
> include/linux/hid-sensor-hub.h | 10 +++++-----
> 1 file changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/include/linux/hid-sensor-hub.h b/include/linux/hid-sensor-hub.h
> index 0f9f7df865db..3621d35a00d6 100644
> --- a/include/linux/hid-sensor-hub.h
> +++ b/include/linux/hid-sensor-hub.h
> @@ -17,7 +17,7 @@
> * @attrib_id: Attribute id for this attribute.
> * @report_id: Report id in which this information resides.
> * @index: Field index in the report.
> - * @units: Measurment unit for this attribute.
> + * @units: Measurement unit for this attribute.
> * @unit_expo: Exponent used in the data.
> * @size: Size in bytes for data size.
> * @logical_minimum: Logical minimum value for this attribute.
> @@ -39,8 +39,8 @@ struct hid_sensor_hub_attribute_info {
> * struct sensor_hub_pending - Synchronous read pending information
> * @status: Pending status true/false.
> * @ready: Completion synchronization data.
> - * @usage_id: Usage id for physical device, E.g. Gyro usage id.
> - * @attr_usage_id: Usage Id of a field, E.g. X-AXIS for a gyro.
> + * @usage_id: Usage id for physical device, e.g. gyro usage id.
> + * @attr_usage_id: Usage Id of a field, e.g. X-AXIS for a gyro.
I don't think "axis" needs to be all caps either. This is a numeric fields, so
it's not like this is a string literal and there is a dash in the name so I
don't think the intention was to reference a macro name.
> * @raw_size: Response size for a read request.
> * @raw_data: Place holder for received response.
> */
> @@ -104,10 +104,10 @@ struct hid_sensor_hub_callbacks {
> int sensor_hub_device_open(struct hid_sensor_hub_device *hsdev);
>
> /**
> -* sensor_hub_device_clode() - Close hub device
> +* sensor_hub_device_close() - Close hub device
> * @hsdev: Hub device instance.
> *
> -* Used to clode hid device for sensor hub.
> +* Used to close hid device for sensor hub.
> */
> void sensor_hub_device_close(struct hid_sensor_hub_device *hsdev);
>
Powered by blists - more mailing lists