[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <56012f51fad537efdff61c7db0d6912e56d537e5.camel@intel.com>
Date: Thu, 28 Aug 2025 19:04:10 +0000
From: "Edgecombe, Rick P" <rick.p.edgecombe@...el.com>
To: "seanjc@...gle.com" <seanjc@...gle.com>
CC: "kvm@...r.kernel.org" <kvm@...r.kernel.org>, "pbonzini@...hat.com"
<pbonzini@...hat.com>, "Annapurve, Vishal" <vannapurve@...gle.com>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>, "Zhao, Yan Y"
<yan.y.zhao@...el.com>, "michael.roth@....com" <michael.roth@....com>,
"Weiny, Ira" <ira.weiny@...el.com>
Subject: Re: [RFC PATCH 04/12] KVM: x86/mmu: Rename kvm_tdp_map_page() to
kvm_tdp_prefault_page()
On Thu, 2025-08-28 at 11:50 -0700, Sean Christopherson wrote:
> >
> > I realize you are just trying to do map->prefault here, but "page" seems
> > redundant once you have "prefault" in the name. Why page here vs all the
> > other fault handler functions without it?
>
> kvm_tdp_prefault() feels a bit ambiguous/bare. Many of the fault helpers do
> have "page", it's just before the fault part.
>
> kvm_mmu_finish_page_fault
> kvm_handle_page_fault
> kvm_tdp_page_fault
> direct_page_fault
> nonpaging_page_fault
> kvm_tdp_mmu_page_fault
>
> (and probably more)
True.
>
> How about kvm_tdp_page_prefault()? Or kvm_tdp_do_prefault(), but I think I
> like kvm_tdp_page_prefault() a little more.
kvm_tdp_page_prefault() would be my pick of those.
Powered by blists - more mailing lists