[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20070116085611.GA1003@ff.dom.local>
Date: Tue, 16 Jan 2007 09:56:11 +0100
From: Jarek Poplawski <jarkao2@...pl>
To: Patrick McHardy <kaber@...sh.net>
Cc: netdev@...r.kernel.org, shemminger@...l.org
Subject: Re: [IPROUTE 01/05]: Use tc_calc_xmittime where appropriate
On 10-01-2007 11:01, Patrick McHardy wrote:
> [IPROUTE]: Use tc_calc_xmittime where appropriate
>
> Replace expressions of the form "1000000 * size/rate" by tc_calc_xmittime().
> The CBQ case deserves an extra comment: when called with bnwd=rate
> tc_cbq_calc_maxidle behaves identical to tc_calc_xmittime, so use it
> for clarity.
>
> Signed-off-by: Patrick McHardy <kaber@...sh.net>
>
> ---
...
> diff --git a/tc/tc_red.c b/tc/tc_red.c
> index 385e7af..8f9bde0 100644
> --- a/tc/tc_red.c
> +++ b/tc/tc_red.c
> @@ -71,7 +71,7 @@ int tc_red_eval_ewma(unsigned qmin, unsi
>
> int tc_red_eval_idle_damping(int Wlog, unsigned avpkt, unsigned bps, __u8 *sbuf)
> {
> - double xmit_time = tc_core_usec2tick(1000000*(double)avpkt/bps);
> + double xmit_time = tc_calc_xmittime(bps, avpkt);
Return value changed to unsigned here.
(According to iproute2-2.6.19-061214.)
> double lW = -log(1.0 - 1.0/(1<<Wlog))/xmit_time;
> double maxtime = 31/lW;
> int clog;
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists