lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 4 Jul 2007 14:11:41 +0200
From:	Jarek Poplawski <>
To:	Mark Hannessen <>
Cc:, Satyam Sharma <>
Subject: Re: Via Rhine II Network Card Failure

On 21-06-2007 12:58, Mark Hannessen wrote:
> Hi list,
> I have some trouble getting my network card to run.
> when I run dmesg I can clearly see it being detected
> eth0: VIA Rhine II at 0xee006000, 00:e0:c5:54:88:a8, IRQ 11.
> eth0: MII PHY found at address 1, status 0x786d advertising 05e1 Link 45e1.
> but when I try ifconfig eth0 up it fails with a no device error.
> SIOCSIFADDR: No such device eth0:
> ERROR while getting interface flags: No such device
> I tried adding pci=routeirq too, but that didn't work either.
> I know there is nothing wrong with the card itself because it works on
> the linux distro that came with it.
> does anyone have any hints as to what might get it up and running?

I see the list has been really overworked...

It's a long time and I hope you've found the reason yet.
If not, here are some hints:

- is eth0 shown in /proc e.g. in /proc/interrupts?
- is ifconfig -a returning something?
- can you try ip (from iproute package) e.g. ip link set eth0 up
- do you have the same net options enabled as in this distro:
- maybe you can try to figure something after (as root):
  strace ifconfig eth0 up
or send the output here...

Jarek P.
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to
More majordomo info at

Powered by blists - more mailing lists