lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Mon, 16 Jul 2007 23:59:40 +0200
From:	Francois Romieu <>
To:	Andrew Paprocki <>
Subject: Re: r8169 in 2.6.22 release still not detecting link

Andrew Paprocki <> :
> Just writing to let you know that I'm still not getting a link on
> either r8169 port with the stock 2.6.22 kernel. I haven't been able to
> get any other network interface working on this device yet, as it only
> has a mini-PCI slot and I haven't found working wireless hardware yet.
> If I had a connection, I'd try to git bisect from the last known
> working point (2.6.18), but it is difficult for me to do that given
> the current setup.

You will find a backport of the r8169 driver for the 2.6.18 kernel at
(tarball in the upper directory).

As 2.6.18 corrupts your data and 2.6.22 does not detect the link, it
could help if you tried each patch in the serie (on top of the previous
one) against 2.6.18 until the link is lost.

> Do you have any ideas about where I can place some debugging trace? I
> seem to always be able to get a link by backing off to the upstream
> Realtek driver (6.*).

Ok, that's good to know. I.e. got a link and no data corruption with
2.6.22 ?

To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to
More majordomo info at

Powered by blists - more mailing lists