lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 17 Sep 2007 16:59:26 +0200
From:	Daniel Lezcano <>
To:	Pavel Emelyanov <>
CC:	"Eric W. Biederman" <>,
	Linux Netdev List <>
Subject: Re: [PATCH] Rename struct net to struct netns

Pavel Emelyanov wrote:
> The name struct net is too generic. There already were
> some people who wanted to have some better name (for
> easier grep for example). I propose the struct netns one.
> The patch is (already) huge (sorry), but it's nothing but
>   sed -e s/struct net\>/struct netns/g
> If this name is bad as well, let's select a new one
> before the struct net floods the kernel.

[ SNIP ]

> --- a/include/linux/nsproxy.h
> +++ b/include/linux/nsproxy.h
> @@ -29,7 +29,7 @@ struct nsproxy {
>  	struct mnt_namespace *mnt_ns;
>  	struct pid_namespace *pid_ns;
>  	struct user_namespace *user_ns;
> -	struct net 	     *net_ns;
> +	struct netns 	     *net_ns;

IMHO, if we want to be consistent with all the rest of the namespaces, 
that should be net_namespace.

[ SNIP ]
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to
More majordomo info at

Powered by blists - more mailing lists