lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 15 Oct 2007 15:59:17 +0200
From:	Willy Tarreau <w@....eu>
To:	"Kok, Auke" <auke-jan.h.kok@...el.com>
Cc:	"Brandeburg, Jesse" <jesse.brandeburg@...el.com>,
	netdev@...r.kernel.org, dmpesl <dmpesl@...s.cs.msu.su>
Subject: FWD: 2.4.35 e1000 problems

Hi,

Dmitry, I've forwarded your mail to the netdev mailing list and to
the e1000 maintainers.

Auke, does it sound like a known problem ? Maybe someone has seen it
in 2.6 ? Just for the record, e1000 in 2.4.35 is 7.3.20-k4.

Dmitry, if you have time for a test, I think it would be good if you
could test the most recent driver from e1000.sf.net. It might give
us some more information about the problem's cause. Otherwise, let's
wait for Auke's advices and/or questions.

Regards,
Willy

----- Forwarded message from dmpesl <dmpesl@...s.cs.msu.su> -----

Date: Mon, 15 Oct 2007 17:54:01 +0400 (MSD)
From: dmpesl <dmpesl@...s.cs.msu.su>
Subject: 2.4.35 e1000 problems
To: w@....eu
X-X-Sender: dmpesl@...si.cs.msu.su

Hello, Willy

on recent month i've changed kernel from 2.4.31->2.4.35 on my Owl-based 
web server (purchased SATA hdd, onboard SATA 20378), Asus PCH-DR mb, 
2*Xeon, and noticed that following error occurs on network card:
---------------------------------------------
Sep 29 21:29:51 host kernel: NETDEV WATCHDOG: eth0: transmit timed out
Sep 29 21:29:53 host kernel: e1000: eth0: e1000_watchdog: NIC Link is Up 
100 Mbps Full Duplex, Flow Control: RX/TX
Sep 29 22:28:03 host kernel: NETDEV WATCHDOG: eth0: transmit timed out
Sep 29 22:28:05 host kernel: e1000: eth0: e1000_watchdog: NIC Link is Up 
100 Mbps Full Duplex, Flow Control: RX/TX
Sep 30 00:51:35 host kernel: NETDEV WATCHDOG: eth0: transmit timed out
Sep 30 00:51:37 host kernel: e1000: eth0: e1000_watchdog: NIC Link is Up 
100 Mbps Full Duplex, Flow Control: RX/TX
---------------------------------------------
After some conversation with my collocation provider (changing cables and 
switch port) i've searched google to same errors and found some advises to 
use ethtool -k tso off, but this is not work with my kernel/distribution.
Then i swapped just e1000 driver in 2.4.35 to older, from 2.4.31.
Now everything works, without loosing link.

Regards, Dmitry

----- End forwarded message -----
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists