[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <A7F393C1-AEAC-4BC5-B7A4-A9CC78179CDF@holtmann.org>
Date: Fri, 18 Apr 2008 23:04:57 +0200
From: Marcel Holtmann <marcel@...tmann.org>
To: akpm@...ux-foundation.org
Cc: hidave.darkstar@...il.com, linux-bluetooth@...r.kernel.org,
netdev@...r.kernel.org, pavel@....cz, pavel@...e.cz
Subject: Re: [patch 1/3] hci_usb: do not initialize static variables to 0
Hi Andrew,
> hci_usb: do not initialize static variables to 0.
>
> Signed-off-by: Pavel Machek <pavel@...e.cz>
> Cc: Marcel Holtmann <marcel@...tmann.org>
> Cc: Dave Young <hidave.darkstar@...il.com>
> Signed-off-by: Andrew Morton <akpm@...ux-foundation.org>
> ---
>
> drivers/bluetooth/hci_usb.c | 14 +++++++-------
> 1 file changed, 7 insertions(+), 7 deletions(-)
>
> diff -puN drivers/bluetooth/hci_usb.c~hci_usb-do-not-initialize-
> static-variables-to-0 drivers/bluetooth/hci_usb.c
> --- a/drivers/bluetooth/hci_usb.c~hci_usb-do-not-initialize-static-
> variables-to-0
> +++ a/drivers/bluetooth/hci_usb.c
> @@ -62,13 +62,13 @@
> #define URB_ZERO_PACKET 0
> #endif
>
> -static int ignore = 0;
> -static int ignore_dga = 0;
> -static int ignore_csr = 0;
> -static int ignore_sniffer = 0;
> -static int disable_scofix = 0;
> -static int force_scofix = 0;
> -static int reset = 0;
> +static int ignore;
> +static int ignore_dga;
> +static int ignore_csr;
> +static int ignore_sniffer;
> +static int disable_scofix;
> +static int force_scofix;
> +static int reset;
I know that some people don't like to do it and I agree, but in case
of module parameters, I prefer to have them clearly indicate what the
default value is. It is a lot easier to read for other people looking
at the code. So that one is a NAK from my side.
Regards
Marcel
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists