[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <alpine.DEB.2.00.0908311538050.29341@wel-95.cs.helsinki.fi>
Date: Mon, 31 Aug 2009 16:22:58 +0300 (EEST)
From: "Ilpo Järvinen" <ilpo.jarvinen@...sinki.fi>
To: Damian Lukowski <damian@....rwth-aachen.de>
cc: Netdev <netdev@...r.kernel.org>, David Miller <davem@...emloft.net>
Subject: Re: [PATCH 1/3] Revert Backoff [v3]: Rename skb to icmp_skb in
tcp_v4_err()
On Wed, 26 Aug 2009, Damian Lukowski wrote:
> This supplementary patch renames skb to icmp_skb in tcp_v4_err() in order to
> disambiguate from another sk_buff variable, which will be introduced
> in a separate patch.
>
> Signed-off-by: Damian Lukowski <damian@....rwth-aachen.de>
> ---
> net/ipv4/tcp_ipv4.c | 16 ++++++++--------
> 1 files changed, 8 insertions(+), 8 deletions(-)
>
> diff --git a/net/ipv4/tcp_ipv4.c b/net/ipv4/tcp_ipv4.c
> index 6d88219..6ca1bc8 100644
> --- a/net/ipv4/tcp_ipv4.c
> +++ b/net/ipv4/tcp_ipv4.c
> @@ -328,26 +328,26 @@ static void do_pmtu_discovery(struct sock *sk, struct iphdr *iph, u32 mtu)
> *
> */
>
> -void tcp_v4_err(struct sk_buff *skb, u32 info)
> +void tcp_v4_err(struct sk_buff *icmp_skb, u32 info)
> {
> - struct iphdr *iph = (struct iphdr *)skb->data;
> - struct tcphdr *th = (struct tcphdr *)(skb->data + (iph->ihl << 2));
> + struct iphdr *iph = (struct iphdr *)icmp_skb->data;
> + struct tcphdr *th = (struct tcphdr *)(icmp_skb->data + (iph->ihl << 2));
> struct tcp_sock *tp;
> struct inet_sock *inet;
> - const int type = icmp_hdr(skb)->type;
> - const int code = icmp_hdr(skb)->code;
> + const int type = icmp_hdr(icmp_skb)->type;
> + const int code = icmp_hdr(icmp_skb)->code;
> struct sock *sk;
> __u32 seq;
> int err;
> - struct net *net = dev_net(skb->dev);
> + struct net *net = dev_net(icmp_skb->dev);
>
> - if (skb->len < (iph->ihl << 2) + 8) {
> + if (icmp_skb->len < (iph->ihl << 2) + 8) {
Not that related to the purpose of this patch but still worth to
mention now that we are in the context... ...I wonder if this should be
pskb_may_pull instead of direct compare here regardless of this change?
> ICMP_INC_STATS_BH(net, ICMP_MIB_INERRORS);
> return;
> }
>
> sk = inet_lookup(net, &tcp_hashinfo, iph->daddr, th->dest,
> - iph->saddr, th->source, inet_iif(skb));
> + iph->saddr, th->source, inet_iif(icmp_skb));
> if (!sk) {
> ICMP_INC_STATS_BH(net, ICMP_MIB_INERRORS);
> return;
>
Acked-by: Ilpo Järvinen <ilpo.jarvinen@...sinki.fi>
--
i.
Powered by blists - more mailing lists