[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4ACDFB1C.4090107@gmail.com>
Date: Thu, 08 Oct 2009 16:45:48 +0200
From: Eric Dumazet <eric.dumazet@...il.com>
To: Neil Horman <nhorman@...driver.com>
CC: netdev@...r.kernel.org, davem@...emloft.net, socketcan@...tkopp.net
Subject: Re: [PATCH] Generalize socket rx gap / receive queue overflow cmsg
Neil Horman a écrit :
>>> + if (check_drops) {
>>> + skb = skb_recv_datagram(sk, flags|MSG_PEEK,
>>> + flags & MSG_DONTWAIT, &err);
>> Ouch, this is too expensive, please find another way :)
>>
>>> + if (skb) {
>>> + gap = skb->dropcount;
>>> + consume_skb(skb);
>>> + }
>>> + }
>>> +
> I'm not sure that I see the expense here, and what expense there is, I don't see
> how it avoidable. In order to do this reporting at the socket level, we need to
> look at the skb at the head of the receive queue. But we need to do so in a way
> thats consistent with the flags being passed in (i.e. if this is a blocking
> socket, we need to block here until something is available to read). Then its
> just an atomic_inc on skb->users, followed by a dec in the consume_skb. I could
> implement the logic for DONTWAIT myself, and skip the atomic_inc/dec, but I'm
> not sure thats much of a savings. If you have another thought, I'm certainly
> open to it.
The expense is a lot of atomic ops. You forgot the lock, so thats four atomic ops.
You can do all this with no extra atomics.
All you need is some function with (struct msghdr *msg, struct sock *sk, struct sk_buff *skb)
triplet.
hint : sock_recv_timestamp(struct msghdr *msg, struct sock *sk, struct sk_buff *skb)
Could be renamed to something else if you want...
sock_recv_ts_or_drops() or whatever
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists