[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20091008172029.GB23928@hmsreliant.think-freely.org>
Date: Thu, 8 Oct 2009 13:20:29 -0400
From: Neil Horman <nhorman@...driver.com>
To: Eric Dumazet <eric.dumazet@...il.com>
Cc: netdev@...r.kernel.org, davem@...emloft.net, socketcan@...tkopp.net
Subject: Re: [PATCH] Generalize socket rx gap / receive queue overflow cmsg
On Thu, Oct 08, 2009 at 04:45:48PM +0200, Eric Dumazet wrote:
> Neil Horman a écrit :
> >>> + if (check_drops) {
> >>> + skb = skb_recv_datagram(sk, flags|MSG_PEEK,
> >>> + flags & MSG_DONTWAIT, &err);
> >> Ouch, this is too expensive, please find another way :)
> >>
> >>> + if (skb) {
> >>> + gap = skb->dropcount;
> >>> + consume_skb(skb);
> >>> + }
> >>> + }
> >>> +
> > I'm not sure that I see the expense here, and what expense there is, I don't see
> > how it avoidable. In order to do this reporting at the socket level, we need to
> > look at the skb at the head of the receive queue. But we need to do so in a way
> > thats consistent with the flags being passed in (i.e. if this is a blocking
> > socket, we need to block here until something is available to read). Then its
> > just an atomic_inc on skb->users, followed by a dec in the consume_skb. I could
> > implement the logic for DONTWAIT myself, and skip the atomic_inc/dec, but I'm
> > not sure thats much of a savings. If you have another thought, I'm certainly
> > open to it.
>
> The expense is a lot of atomic ops. You forgot the lock, so thats four atomic ops.
>
> You can do all this with no extra atomics.
>
> All you need is some function with (struct msghdr *msg, struct sock *sk, struct sk_buff *skb)
> triplet.
>
> hint : sock_recv_timestamp(struct msghdr *msg, struct sock *sk, struct sk_buff *skb)
>
> Could be renamed to something else if you want...
>
> sock_recv_ts_or_drops() or whatever
Ok, but that will require moving the flag that we're triggering this on down
into the sock structure, and not doing the check up in __sock_recvmsg, but I
suppose thats fine. Ok, I'll repost soon. Thanks!
Neil
> --
> To unsubscribe from this list: send the line "unsubscribe netdev" in
> the body of a message to majordomo@...r.kernel.org
> More majordomo info at http://vger.kernel.org/majordomo-info.html
>
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists