lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Thu, 12 Aug 2010 13:14:04 +0300
From:	Luciano Coelho <>
To:	ext Jan Engelhardt <>
Cc:	"" <>,
	"" <>,
	"" <>,
	"" <>,
	"Ylalehto Janne (Nokia-MS/Tampere)" <>
Subject: Re: [PATCH 0/1] netfilter: xt_condition: add condition target

On Thu, 2010-08-12 at 12:10 +0200, ext Jan Engelhardt wrote:
> On Thursday 2010-08-12 08:37, Luciano Coelho wrote:
> >
> >One thing that came to my mind was whether it would make sense to
> >rename this match/target combo to "variable" instead of "condition".
> >To me it makes more sense to call it variable than condition, since
> >I have changed the value from boolean to u32. On the other hand, it
> >could become very confusing because it used to be called condition
> >in its xtables-addons days...
> To improve matters, POSIX has something called "condition variables".
> So oh well let's just leave it as-is :)


Okay, let's keep it like this, I guess it would just complicate things
more if we change it.


To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to
More majordomo info at

Powered by blists - more mailing lists