[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4D08F4F4.3050501@trash.net>
Date: Wed, 15 Dec 2010 18:03:48 +0100
From: Patrick McHardy <kaber@...sh.net>
To: Eric Dumazet <eric.dumazet@...il.com>
CC: David Miller <davem@...emloft.net>,
netdev <netdev@...r.kernel.org>,
Jarek Poplawski <jarkao2@...il.com>
Subject: Re: [PATCH v2] net_sched: sch_sfq: fix allot handling
On 15.12.2010 17:55, Eric Dumazet wrote:
> Le mercredi 15 décembre 2010 à 17:43 +0100, Patrick McHardy a écrit :
>
>> Now we could remove the allot increase in sfq_dequeue for
>> the case that the flow becomes inactive. It is incorrect
>> anyways.
>
> Hmm, we increase the allot for the next slot, not for the slot now
> empty.
>
>
> /* Is the slot empty? */
> if (q->qs[a].qlen == 0) {
> q->ht[q->hash[a]] = SFQ_DEPTH;
> a = q->next[a]; // a = next slot index
> if (a == old_a) {
> q->tail = SFQ_DEPTH;
> return skb;
> }
> q->next[q->tail] = a;
> q->allot[a] += q->quantum;
> // HERE, q->allot[a] is for next slot, we give it its quantum for being
> activated
Right, that's odd. It shouldn't be necessary anymore though since
now we initialize allot in sfq_enqueue() for all new flows and
increase allotment for all active flows once per round in sfq_dequeue().
The above code causes a second increase for the flow following a flow
which went inactive.
>
> } else if ((q->allot[a] -= qdisc_pkt_len(skb)) <= 0) {
>
> Maybe we should rename (a / old_a) by (a / next_a) to avoid confusion :)
That might have made things more clearer :)
> I was thinking in allowing more packets per SFQ (but keep the 126 active
> flows limit), what do you think ?
I keep forgetting why this limit exists, let me try to figure
it out once more :)
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists