[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <BANLkTin52LqjxtVT+_y+gGam-QxeLq_iOA@mail.gmail.com>
Date: Fri, 1 Apr 2011 19:07:05 -0700
From: Mahesh Bandewar <maheshb@...gle.com>
To: linux-netdev <netdev@...r.kernel.org>,
Ben Hutchings <bhutchings@...arflare.com>,
Michał Mirosław <mirq-linux@...e.qmqm.pl>,
David Miller <davem@...emloft.net>
Subject: extending feature word.
Thanks for your comments on my loop-back patch. I was looking at the
code today from the perspective of extending various "features" for
word to an array of words and as Michael has pointed out, it's a huge
change. So I'm thinking on the following lines
(include/linux/netdevice.h)
+#define DEV_FEATURE_WORDS 2
+#define LEGACY_FEATURE_WORD 0
/* currently active device features */
- u32 features;
+ u32 features[DEV_FEATURE_WORDS];
/* user-changeable features */
- u32 hw_features;
+ u32 hw_features[DEV_FEATURE_WORDS];
/* user-requested features */
- u32 wanted_features;
+ u32 wanted_features[DEV_FEATURE_WORDS];
/* VLAN feature mask */
- u32 vlan_features;
+ u32 vlan_features[DEV_FEATURE_WORDS];
+#define legacy_features features[LEGACY_FEATURE_WORD]
+#define legacy_hw_features hw_features[LEGACY_FEATURE_WORD]
+#define legacy_wanted_features wanted_features[LEGACY_FEATURE_WORD]
+#define legacy_vlan_features vlan_features[LEGACY_FEATURE_WORD]
So that it will be a matter of -
s/features/legacy_features/
s/hw_features/legacy_hw_features/
s/wanted_features/legacy_wanted_features/
s/vlan_features/legacy_vlan_features/
to start with as a first step. Once this is done, legacy_* can be
changed with respective arrays and modified as per the need. Comments?
--mahesh..
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists