[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1301712946.10056.179.camel@localhost>
Date: Sat, 02 Apr 2011 03:55:46 +0100
From: Ben Hutchings <bhutchings@...arflare.com>
To: Amit Salecha <amit.salecha@...gic.com>
Cc: "davem@...emloft.net" <davem@...emloft.net>,
"netdev@...r.kernel.org" <netdev@...r.kernel.org>,
Ameen Rahman <ameen.rahman@...gic.com>,
Sucheta Chakraborty <sucheta.chakraborty@...gic.com>,
Anirban Chakraborty <anirban.chakraborty@...gic.com>
Subject: RE: [PATCH] net: ethtool support to configure number of channels
On Fri, 2011-04-01 at 21:36 -0500, Amit Salecha wrote:
> > I'm not sure why you reduced this to a single count. If if the driver
> > or hardware doesn't allow certain combinations of counts, it might be
> > necessary to configure several types at the same time
> >
> > > +/* Channel ID is made up of a type */
> > > +enum ethtool_channel_id {
> > > + ETH_CHAN_TYPE_RX = 0x1,
> > > + ETH_CHAN_TYPE_TX = 0x2
> > > +};
> > [...]
> >
> > enum ethtool_channel_id was meant to be an identifier of a specific
> > channel. An enumeration of channel types should be named differently.
> >
>
> I will name it as ethtool_channel_type. Any other suggestion ?
>
> > This also omits the 'combined' and 'other' types. Most multiqueue
> > drivers pair up RX and TX queues so that most channels combine RX and
> > TX
> > work.
>
> 'combined' is ok, what is use of 'other' ?
Could be link interrupts, SR-IOV coordination, or something else. Not
something you'd likely be able to change, but it could be useful to know
that some interrupts are allocated to them. Actually, that does mean it
might be helpful for the 'get' operation to return a minimum value along
with the maximum value.
Ben.
--
Ben Hutchings, Senior Software Engineer, Solarflare Communications
Not speaking for my employer; that's the marketing department's job.
They asked us to note that Solarflare product names are trademarked.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists