[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20110921115821.GF28907@S2100-06.ap.freescale.net>
Date: Wed, 21 Sep 2011 19:58:22 +0800
From: Shawn Guo <shawn.guo@...escale.com>
To: Wolfram Sang <w.sang@...gutronix.de>
CC: Shawn Guo <shawn.guo@...aro.org>,
"David S. Miller" <davem@...emloft.net>, <patches@...aro.org>,
<netdev@...r.kernel.org>,
Troy Kisky <troy.kisky@...ndarydevices.com>,
Francois Romieu <romieu@...zoreil.com>,
<linux-arm-kernel@...ts.infradead.org>,
Lothar Waßmann <LW@...O-electronics.de>
Subject: Re: [PATCH v2 3/3] net/fec: add imx6q enet support
On Wed, Sep 21, 2011 at 01:32:39PM +0200, Wolfram Sang wrote:
>
> > +/* Controller has GBIT support */
> > +#define FEC_QUIRK_HAS_GBIT (1 << 3)
>
> Heh, this is not really a quirk, but a nice feature :) I think we can
> drop QUIRK if we see driver_data more as "flags" instead of "quirks"?
> Minor, though.
>
As you have told, all these FEC_QUIRK_* are just flags actually. The
name was pick to keep the consistency, as they are all used for the
same purpose.
> > MODULE_DEVICE_TABLE(of, fec_dt_ids);
> > @@ -373,6 +383,7 @@ fec_restart(struct net_device *ndev, int duplex)
> > int i;
> > u32 temp_mac[2];
> > u32 rcntl = OPT_FRAME_SIZE | 0x04;
> > + u32 ecntl = 0x2; /* ETHEREN */
>
> Also minor, but the patch looks like a good oportunity to start
> replacing magic values with proper defines?
>
There are already so many magic numbers. It really deserves a separated
patch.
I heard that Uwe had a plan to do that some time ago. He gives up
now? :)
--
Regards,
Shawn
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists