[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1344585156.29601.4.camel@cr0>
Date: Fri, 10 Aug 2012 15:52:36 +0800
From: Cong Wang <amwang@...hat.com>
To: Jiri Pirko <jiri@...nulli.us>
Cc: netdev@...r.kernel.org, Jiri Pirko <jpirko@...hat.com>,
David Miller <davem@...emloft.net>
Subject: Re: [PATCH 09/14] netpoll: check netpoll tx status on the right
device
On Fri, 2012-08-10 at 09:20 +0200, Jiri Pirko wrote:
> >
> >+static inline int team_dev_queue_xmit(struct team *team, struct team_port *port,
> >+ struct sk_buff *skb)
> >+{
> >+ BUILD_BUG_ON(sizeof(skb->queue_mapping) !=
> >+ sizeof(qdisc_skb_cb(skb)->slave_dev_queue_mapping));
> >+ skb_set_queue_mapping(skb, qdisc_skb_cb(skb)->slave_dev_queue_mapping);
> >+
> >+ skb->dev = port->dev;
> >+ if (unlikely(netpoll_tx_running(team->dev))) {
> >+ team_netpoll_send_skb(port, skb);
> >+ return 0;
> >+ }
> >+ return dev_queue_xmit(skb);
> >+}
> >+
>
> Is there any particular reason for moving the whole function?
In the changelog I mentioned:
"For team_dev_queue_xmit() we have to move it down to avoid
compile errors."
Or you mean this isn't clear? As I changed 'port->dev' to 'team->dev',
so the definition of 'struct team' has to be visual to
team_dev_queue_xmit(), therefore I moved to down after that definition.
Thanks!
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists