lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 3 Jan 2014 16:43:37 -0800
From:	Cong Wang <xiyou.wangcong@...il.com>
To:	David Miller <davem@...emloft.net>
Cc:	Linux Kernel Network Developers <netdev@...r.kernel.org>
Subject: Re: [PATCH net-next] net: unify the pcpu_tstats and br_cpu_netstats

On Fri, Jan 3, 2014 at 4:32 PM, David Miller <davem@...emloft.net> wrote:
> From: Cong Wang <xiyou.wangcong@...il.com>
> Date: Fri, 3 Jan 2014 04:53:47 +0000 (UTC)
>
>> On Thu, 02 Jan 2014 at 08:57 GMT, roy.qing.li@...il.com <roy.qing.li@...il.com> wrote:
>>> From: Li RongQing <roy.qing.li@...il.com>
>>>
>>> They are same, so unify them as one, pcpu_tstats.
>>> and move pcpu_tstat into netdevice.h
>>>
>>
>> tstats means Tunnel STATS, right? So, it has to be
>> in if_tunnel.h.
>
> They are being used in the bridging code now, did you read the
> patch?
>
> So not really limited to just tunnels, and therefore they really do
> belong somewhere generic like netdevice.h

I knew, my point is we should find a better name than "tstat".

>
> This also means that since they are now an encapsulation thing we
> should rename them to pcpu_encap_stats or similar, thanks.

Not sure "encap" makes sense for bridge too.

Thanks.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists