[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <7c9810ea21990e7e239b101f548818f7.squirrel@webmail.itwm.fhg.de>
Date: Wed, 5 Mar 2014 20:15:56 +0100
From: "Phoebe Buckheister" <phoebe.buckheister@...m.fraunhofer.de>
To: "David Miller" <davem@...emloft.net>
Cc: phoebe.buckheister@...m.fraunhofer.de, netdev@...r.kernel.org,
linux-zigbee-devel@...ts.sourceforge.net
Subject: Re: [PATCH net-next v4 1/4] ieee802154: add generic header
handling routines
> From: Phoebe Buckheister <phoebe.buckheister@...m.fraunhofer.de>
> Date: Tue, 4 Mar 2014 15:34:45 +0100
>
>> +struct ieee802154_sechdr {
>> + u8 sc;
>> + u32 frame_ctr;
>> + union {
>> + struct {
>> + u16 pan_id;
>> + u16 short_addr;
>> + } pan;
>> + u8 hw[IEEE802154_ADDR_LEN];
>> + } key_source;
>> + u8 key_id;
>> +};
>> +
>> +struct ieee802154_hdr {
>> + u16 fc;
>> + u8 seq;
>> + struct ieee802154_addr source;
>> + struct ieee802154_addr dest;
>> + struct ieee802154_sechdr sec;
>> +};
>
> You're going to have to address endianness both in these structure
> definitions and the code.
>
> For types larger than u8 you'll need to use __be16, __le16, __be32,
> __le32 etc. as appropriate.
>
> When setting/loading values, you'll need to use cpu_to_be16(),
> cpu_to_le16() etc. as appropriate.
The fc field in struct ieee802154_hdr is a bitfield with many subfields,
the sc field of struct ieee802154_sec_hdr is also a bitfield. Would it be
acceptable to represent them as bitfields in the header struct? I expect
the code to be just as efficient in every respect, but more readable since
we wouldn't need explicit shifts and masks everywhere.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists