[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1395699924.12610.83.camel@edumazet-glaptop2.roam.corp.google.com>
Date: Mon, 24 Mar 2014 15:25:24 -0700
From: Eric Dumazet <eric.dumazet@...il.com>
To: Tom Herbert <therbert@...gle.com>
Cc: davem@...emloft.net, netdev@...r.kernel.org
Subject: Re: [PATCH net-next 1/4] net: Rename rxhash to hash
On Thu, 2014-03-20 at 17:09 -0700, Tom Herbert wrote:
> diff --git a/net/packet/af_packet.c b/net/packet/af_packet.c
> index 2923044..125887c 100644
> --- a/net/packet/af_packet.c
> +++ b/net/packet/af_packet.c
> @@ -1277,7 +1277,7 @@ static unsigned int fanout_demux_hash(struct packet_fanout *f,
> struct sk_buff *skb,
> unsigned int num)
> {
> - return reciprocal_scale(skb->rxhash, num);
> + return reciprocal_scale(skb_get_hash(skb), num);
> }
>
> static unsigned int fanout_demux_lb(struct packet_fanout *f,
It seems that you could remove the skb_get_hash(skb) before the call to
fanout_demux_hash() then.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists