lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Sun, 1 Jun 2014 09:26:57 +0200
From:	Alexander Aring <alex.aring@...il.com>
To:	Jean Sacren <sakiwit@...il.com>
Cc:	Alexander Smirnov <alex.bluesman.smirnov@...il.com>,
	Dmitry Eremin-Solenikov <dbaryshkov@...il.com>,
	linux-zigbee-devel@...ts.sourceforge.net, netdev@...r.kernel.org
Subject: Re: [PATCH net-next] ieee802154: use helper function to get rid of
 redundancy

Hi Jean,

the at86rf230 driver supports several at86rf2xx chips. You split the
at86rf212_set_channel which is at86rf212 specific in two function which
are named at86rf230_foo.

Sorry, but I think we should not do this. One reason is that the code is
much easier to read when we have one channel_set callback for at86rf23x
and at86rf212 chips.



Btw. I preparing a big cleanup for this driver which supports regmap and
asychronous handling for rx/tx paths.

- Alex

--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists