lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Sun, 1 Jun 2014 08:23:17 -0600
From:	Jean Sacren <>
To:	Alexander Aring <>
Cc:	Alexander Smirnov <>,
	Dmitry Eremin-Solenikov <>,,
Subject: Re: [PATCH net-next] ieee802154: use helper function to get rid of

From: Alexander Aring <>
Date: Sun, 01 Jun 2014 09:26:57 +0200

Hi Alex,

Thank you very much for the feedback.

> the at86rf230 driver supports several at86rf2xx chips. You split the
> at86rf212_set_channel which is at86rf212 specific in two function which
> are named at86rf230_foo.

I didn't "split" at86rf212_set_channel() in two functions. I spliced
those two sections of code and made at86rf212_set_channel() far
succinct and easy to read.

> Sorry, but I think we should not do this. One reason is that the code is
> much easier to read when we have one channel_set callback for at86rf23x
> and at86rf212 chips.

If you use one channel_set callback as before the change, how would you
overcome the redundancy?

> Btw. I preparing a big cleanup for this driver which supports regmap and
> asychronous handling for rx/tx paths.

Thank you for letting me know. I'm sure I will learn a lot.
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to
More majordomo info at

Powered by blists - more mailing lists